summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-07-05 11:32:22 -0700
committerxiota2023-07-05 11:32:22 -0700
commit567f9abc7c506a89185714a49073269e4f6f9f6b (patch)
tree91a75448bfe023ff64985bf81002dad5768d8560
parent34fdfa2ef554a906f9c324cef284083c250e9ecb (diff)
downloadaur-567f9abc7c506a89185714a49073269e4f6f9f6b.tar.gz
4.2.0.r27: update depends, provides
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 37 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01a1ed88a48a..b2ae0715fdce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,29 @@
pkgbase = libgweather-git
pkgdesc = Location and timezone database and weather-lookup library
- pkgver = 4.2.0.r26.g9dd18c95
+ pkgver = 4.2.0.r27.g93127506
pkgrel = 1
- url = https://wiki.gnome.org/Projects/LibGWeather
+ url = https://gitlab.gnome.org/GNOME/libgweather
arch = x86_64
license = LGPL
- makedepends = gobject-introspection
- makedepends = vala
- makedepends = git
makedepends = gi-docgen
- makedepends = glade
+ makedepends = git
+ makedepends = gobject-introspection
makedepends = meson
makedepends = python-gobject
- depends = geocode-glib-2
+ makedepends = vala
depends = dconf
+ depends = geocode-glib-2
+ depends = json-glib
+ depends = libsoup3
+ depends = libxml2
provides = libgweather
provides = libgweather-4
conflicts = libgweather
conflicts = libgweather-4
- source = git+https://gitlab.gnome.org/GNOME/libgweather.git
+ source = libgweather::git+https://gitlab.gnome.org/GNOME/libgweather
sha256sums = SKIP
pkgname = libgweather-git
+ provides = libgweather
+ provides = libgweather-4
+ provides = libgweather-4.so
diff --git a/PKGBUILD b/PKGBUILD
index ccb31f4d7b7e..a891667c3920 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,38 @@
-# Maintainer: Ignacy Kuchciński (ignapk) <ignacykuchcinski@gmail.com>
+# Maintainer:
+# Contributor: Ignacy Kuchciński (ignapk) <ignacykuchcinski@gmail.com>
-_pkgname="libgweather"
+_pkgname='libgweather'
pkgname="$_pkgname-git"
-pkgver=4.2.0.r26.g9dd18c95
+pkgver=4.2.0.r27.g93127506
pkgrel=1
-pkgdesc="Location and timezone database and weather-lookup library"
-url="https://wiki.gnome.org/Projects/LibGWeather"
+pkgdesc='Location and timezone database and weather-lookup library'
+url='https://gitlab.gnome.org/GNOME/libgweather'
arch=(x86_64)
license=(LGPL)
+
depends=(
- 'geocode-glib-2'
'dconf'
+ 'geocode-glib-2'
+ 'json-glib'
+ 'libsoup3'
+ 'libxml2'
)
makedepends=(
- 'gobject-introspection'
- 'vala'
- 'git'
'gi-docgen'
- 'glade'
+ 'git'
+ 'gobject-introspection'
'meson'
'python-gobject'
+ 'vala'
)
+
provides=(
'libgweather'
- 'libgweather-4')
+ 'libgweather-4'
+)
conflicts=(${provides[@]})
-source=("git+https://gitlab.gnome.org/GNOME/libgweather.git")
+
+source=("$_pkgname"::"git+$url")
sha256sums=('SKIP')
pkgver() {
@@ -33,20 +40,19 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/$_pkgname"
-}
-
build() {
arch-meson "$_pkgname" build -D gtk_doc=true
meson compile -C build
}
check() {
- # Test fails without fr_FR.UTF-8 locale
meson test -C build --print-errorlogs || :
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ provides+=(
+ 'libgweather-4.so'
+ )
+
+ meson install -C build --destdir "$pkgdir"
}