summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWouter2021-07-29 21:37:02 +0200
committerWouter2021-07-29 22:02:51 +0200
commit568cfb1cfff722a24a6ec3b951a4c990af54a0e9 (patch)
treeb92c2e24b27dfa115cd87ab0a7605c736f00e1e8
downloadaur-568cfb1cfff722a24a6ec3b951a4c990af54a0e9.tar.gz
Repo init
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
-rw-r--r--flathub.gpgbin0 -> 2844 bytes
-rw-r--r--steamlink.sh2
5 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d20e2ed6afb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = steamlink
+ pkgdesc = Steam Link client
+ pkgver = 1.1.81.199
+ pkgrel = 1
+ url = https://store.steampowered.com/remoteplay#anywhere
+ arch = x86_64
+ license = custom
+ makedepends = ostree
+ makedepends = fakeroot
+ depends = icu67
+ source = flathub.gpg
+ source = steamlink.sh
+ sha256sums = 8bdc20abc4e19c0796460beb5bfe0e7aa4138716999e19c6f2dbdd78cc41aeaa
+ sha256sums = 4d5bd2835b7ccf71e53e0f6f2c4bc9a3fe2477345cb51517f05b019dd63b8fe8
+
+pkgname = steamlink
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..256e8f472fe3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.log
+*.log.*
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8d6dd1cd2e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=steamlink
+_name=steamlink
+pkgver=1.1.81.199
+pkgrel=1
+pkgdesc="Steam Link client"
+arch=('x86_64')
+url="https://store.steampowered.com/remoteplay#anywhere"
+license=('custom')
+depends=('icu67')
+makedepends=('ostree' 'fakeroot')
+source=(
+ "flathub.gpg"
+ "steamlink.sh"
+)
+sha256sums=('8bdc20abc4e19c0796460beb5bfe0e7aa4138716999e19c6f2dbdd78cc41aeaa'
+ '4d5bd2835b7ccf71e53e0f6f2c4bc9a3fe2477345cb51517f05b019dd63b8fe8')
+
+build() {
+ mkdir -p ostree
+ ostree init --repo ./ostree
+ ostree remote add --gpg-import=flathub.gpg --repo ./ostree flathub https://dl.flathub.org/repo/ || true
+ fakeroot ostree pull --repo ./ostree flathub app/com.valvesoftware.SteamLink/x86_64/stable
+ ostree export --repo ./ostree flathub:app/com.valvesoftware.SteamLink/x86_64/stable --subpath files > steamlink.tar
+}
+
+package() {
+ mkdir -p $pkgdir/opt/steamlink
+ tar -xf ./steamlink.tar -C $pkgdir/opt/steamlink bin/ lib/ README.txt
+
+ # Wrapper script - needed as we need Steam's shipped libraries
+ install -Dm755 $srcdir/steamlink.sh $pkgdir/usr/bin/steamlink
+
+ # desktop entry / icon
+ mkdir -p $pkgdir/usr
+ tar -xf ./steamlink.tar -C $pkgdir/usr share/applications/ share/icons/
+ sed -i 's/\/app\/bin/\/usr\/bin/g' $pkgdir/usr/share/applications/com.valvesoftware.SteamLink.desktop
+
+ # License
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ tar -xf ./steamlink.tar -C $pkgdir/usr/share/licenses/$pkgname LICENSE.txt ThirdPartyLegalNotices.css ThirdPartyLegalNotices.html
+}
diff --git a/flathub.gpg b/flathub.gpg
new file mode 100644
index 000000000000..79880f65bc23
--- /dev/null
+++ b/flathub.gpg
Binary files differ
diff --git a/steamlink.sh b/steamlink.sh
new file mode 100644
index 000000000000..5d3897ea7d4c
--- /dev/null
+++ b/steamlink.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+LD_LIBRARY_PATH=/opt/steamlink/lib /opt/steamlink/bin/steamlink $@