summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-12-04 14:10:46 -0200
committerDaniel Bermond2017-12-04 14:10:46 -0200
commit56908fc94f4c80f487e1a5b1177c98dc60ad3631 (patch)
tree30e4a8e56b651b5d0d7d3ea9d5e0d1602dd400a7
downloadaur-56908fc94f4c80f487e1a5b1177c98dc60ad3631.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3c150f41c67
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon Dec 4 16:10:33 UTC 2017
+pkgbase = crossc-git
+ pkgdesc = Portable C wrapper for SPIRV-Cross (git version)
+ pkgver = 1.0.0.r2.g1b9df97
+ pkgrel = 1
+ url = https://github.com/rossy/crossc/
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ depends = gcc-libs
+ provides = crossc
+ conflicts = crossc
+ source = crossc-git::git+https://github.com/rossy/crossc.git
+ source = SPIRV-Cross::git+https://github.com/KhronosGroup/SPIRV-Cross.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = crossc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c73e37ad178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
+
+pkgname=crossc-git
+pkgver=1.0.0.r2.g1b9df97
+pkgrel=1
+pkgdesc='Portable C wrapper for SPIRV-Cross (git version)'
+arch=('i686' 'x86_64')
+url='https://github.com/rossy/crossc/'
+license=('unknown')
+depends=('gcc-libs')
+makedepends=('git')
+provides=('crossc')
+conflicts=('crossc')
+source=("$pkgname"::'git+https://github.com/rossy/crossc.git'
+ 'SPIRV-Cross'::'git+https://github.com/KhronosGroup/SPIRV-Cross.git')
+sha256sums=('SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "$pkgname"
+
+ git submodule init
+ git config --local 'submodule.SPIRV-Cross.url' "${srcdir}/SPIRV-Cross"
+ git submodule update
+}
+
+pkgver() {
+ cd "$pkgname"
+
+ # git, tags available
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" prefix='/usr' install
+}