summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXesxen2023-04-03 22:07:36 +0200
committerXesxen2023-04-03 22:07:36 +0200
commit56cb1b6d5e6985befb742007caba8a3ab7858068 (patch)
tree78dbe5d356c61eec29a45d5001493c0e883eb9d7
parent78e8c8c000dcbbc5bc9405bf2520bb4fee861606 (diff)
downloadaur-56cb1b6d5e6985befb742007caba8a3ab7858068.tar.gz
Fix up compilation issues
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
2 files changed, 28 insertions, 9 deletions
diff --git a/.gitignore b/.gitignore
index 0a750c422bd8..6dca487ac1bd 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,10 @@ data.zip
VVVVVV/
pkg/
src/
+c-hashmap/
+FAudio/
+lodepng/
+physfs/
+tinyxml2/
*.pkg.tar.*
vvvvvv-mp-11192019-bin
diff --git a/PKGBUILD b/PKGBUILD
index c84ad78f4a3c..580da7e369e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
pkgname=vvvvvv-git
binname=vvvvvv
-pkgver=20201123.9f5f697
+pkgver=20230402.c88f249f
_pkgver=git
-pkgrel=2
+pkgrel=1
pkgdesc='A retro-styled 2D platformer'
arch=('i686' 'x86_64')
url='https://thelettervsixtim.es/'
@@ -16,16 +16,24 @@ provides=('vvvvvv')
conflicts=('vvvvvv')
source=(
"git+https://github.com/TerryCavanagh/VVVVVV.git"
+ "git+https://github.com/lvandeve/lodepng"
+ "git+https://github.com/icculus/physfs/"
+ "git+https://github.com/leethomason/tinyxml2/"
+ "git+https://github.com/FNA-XNA/FAudio"
+ "git+https://github.com/Mashpoe/c-hashmap"
"${binname}.desktop"
"${binname}.sh"
"https://thelettervsixtim.es/makeandplay/data.zip"
)
-sha256sums=(
- 'SKIP'
- '8c704e92e6abc8172d7d9fe726f1a0bba4b8630682745d6daf1f34ce12e0e3e4'
- '883913125c4630d16fe0081d9a96bf65f2bc08ace7fa345613669d827a8ea7c1'
- '6fae3cdec06062d05827d4181c438153f3ea3900437a44db73bcd29799fe57e0'
-)
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '8c704e92e6abc8172d7d9fe726f1a0bba4b8630682745d6daf1f34ce12e0e3e4'
+ '883913125c4630d16fe0081d9a96bf65f2bc08ace7fa345613669d827a8ea7c1'
+ 'c767809594f6472da9f56136e76657e38640d584164a46112250ac6293ecc0ea')
install="${pkgname}.install"
pkgver() {
@@ -34,10 +42,16 @@ pkgver() {
}
prepare() {
- cd VVVVVV/desktop_version
+ cd VVVVVV
echo "Please note: the retrieved data.zip is for personal use only without redistribution"
echo "See also: /usr/share/licenses/vvvvvv-git/LICENSE.md and https://thelettervsixtim.es/makeandplay/"
+
+ git submodule init
+ for submodule in lodepng physfs tinyxml2 FAudio c-hashmap; do
+ git config "submodule.third_party/$submodule.url" "$srcdir/$submodule"
+ done
+ git -c protocol.allow=never -c protocol.file.allow=always submodule update
}
build() {