summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-12-07 16:28:23 +0100
committeraksr2015-12-07 16:28:23 +0100
commit56d1d58fc63dc9c6a090d3511accb63412a31d6a (patch)
treecc6b5d628fe74d815e7827787065caeb16a0106e
downloadaur-56d1d58fc63dc9c6a090d3511accb63412a31d6a.tar.gz
Start.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ad31551bc89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Dec 7 15:28:22 UTC 2015
+pkgbase = wrap-git
+ pkgdesc = A filter for reformatting text by wrapping and filling lines to a given line-width.
+ pkgver = r308.6cc2ad4
+ pkgrel = 1
+ url = https://github.com/paul-j-lucas/wrap
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ provides = wrap
+ conflicts = wrap
+ source = wrap-git::git+https://github.com/paul-j-lucas/wrap.git
+ md5sums = SKIP
+
+pkgname = wrap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9777d6455193
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=wrap-git
+pkgver=r308.6cc2ad4
+pkgrel=1
+epoch=
+pkgdesc="A filter for reformatting text by wrapping and filling lines to a given line-width."
+arch=('i686' 'x86_64')
+url="https://github.com/paul-j-lucas/wrap"
+license=('GPL')
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=('wrap')
+conflicts=('wrap')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/paul-j-lucas/wrap.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ autoreconf -fiv
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}
+