summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJorge Barroso2015-06-15 21:30:33 +0200
committerJorge Barroso2015-06-15 21:30:33 +0200
commit571ecc60c1398b241c65b4a9086f96e8683f6915 (patch)
treef8205da52cd9e65decdfc8122590d16d90ef165d
downloadaur-571ecc60c1398b241c65b4a9086f96e8683f6915.tar.gz
Initial import
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD56
-rw-r--r--gcc45.patch36
-rw-r--r--pinball-0.3.1-cstddef.patch30
-rw-r--r--pinball-0.3.1-hiscore.patch39
-rw-r--r--pinball-0.3.1-lacomment.patch22
-rw-r--r--pinball-0.3.1-strictproto.patch7
-rw-r--r--pinball-0.3.1-sys-ltdl.patch152
-rw-r--r--pinball.install30
9 files changed, 405 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..428bba86794a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = pinball
+ pkgdesc = The Emilia Pinball Project strives to fulfil your needs for a great pinball game in Linux
+ pkgver = 0.3.1
+ pkgrel = 7
+ url = http://pinball.sourceforge.net/
+ install = pinball.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = sh
+ depends = sdl_mixer
+ depends = sdl_image
+ depends = mesa
+ depends = gcc-libs
+ options = !makeflags
+ options = libtool
+ source = http://downloads.sourceforge.net/pinball/pinball-0.3.1.tar.gz
+ source = gcc45.patch
+ source = pinball-0.3.1-cstddef.patch
+ source = pinball-0.3.1-hiscore.patch
+ source = pinball-0.3.1-lacomment.patch
+ source = pinball-0.3.1-strictproto.patch
+ source = pinball-0.3.1-sys-ltdl.patch
+ sha512sums = d54f2635f583be8a7e4bf3463c69c1ab368e1c069dd7c4edffb95df0448faf7e82ddb8f8607d22a7336e2db176134555ca65b613e9d008b38fecb8ad5a818498
+ sha512sums = 06a152fdb864a7fe7953b24d11241dbdb328606d851945d75de6e9284df5e58dac7f71a14e1ce9211c08e33b89aed7bc128f35567aa7b72ddd4f4e89771c5718
+ sha512sums = 90ab03283023ccefe821de910bcea1167b85e660e3891c3d52c6d2000dd1b3de2b33d3d83d90e8ec5d20142d13eeadd1ae92c26ff4620bd52d87a831aad2cd1a
+ sha512sums = aef3011c52203bef1c5b0890048f80af5b8156c2cafd675fcf801f26eda17ee03e67dde22390b2ee46bac9b57003d9287bed3589a17f16dc89bd4f7b9d91102c
+ sha512sums = 94eb8e2530a0268f4ab41441a6900ebdf7a6d47378b9e2c9a5d2946d01a8a42bc246e74818d44b71ba756d80c8fcd627f775757804d15deb36db12eab2851964
+ sha512sums = 515955274ebafc6fdce379695b7877906e71c0dfdad1c4c0d6c71e147315ad402541381609d60cd6e14ebfd923942607031de6832e64f96e2de9f5ca01b49357
+ sha512sums = bcf9ff65d2ac6545764258b7b6039a7688fee6c41830661dc2dca9e00bc1bc4aada22c04ef91e58fdc93077bc163bb345cc282bdae325ede2c10bcbbd43ef967
+
+pkgname = pinball
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d5a90f8ff46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Contributor: Rob McCathie <archaur at rmcc dot com dot au>
+# Contributor: Renato Garcia <fgar.renato@gmail.com>
+# Contributor: dale <dale@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Maintainer: Jorge Barroso <jorge.barroso.11 at gmail dot com>
+
+pkgname=pinball
+pkgver=0.3.1
+pkgrel=7
+pkgdesc="The Emilia Pinball Project strives to fulfil your needs for a great pinball game in Linux"
+arch=('i686' 'x86_64')
+url="http://pinball.sourceforge.net/"
+license=('GPL2')
+depends=('sh' 'sdl_mixer' 'sdl_image' 'mesa' 'gcc-libs')
+options=('!makeflags' 'libtool')
+install=pinball.install
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'gcc45.patch'
+ 'pinball-0.3.1-cstddef.patch'
+ 'pinball-0.3.1-hiscore.patch'
+ 'pinball-0.3.1-lacomment.patch'
+ 'pinball-0.3.1-strictproto.patch'
+ 'pinball-0.3.1-sys-ltdl.patch')
+sha512sums=('d54f2635f583be8a7e4bf3463c69c1ab368e1c069dd7c4edffb95df0448faf7e82ddb8f8607d22a7336e2db176134555ca65b613e9d008b38fecb8ad5a818498'
+ '06a152fdb864a7fe7953b24d11241dbdb328606d851945d75de6e9284df5e58dac7f71a14e1ce9211c08e33b89aed7bc128f35567aa7b72ddd4f4e89771c5718'
+ '90ab03283023ccefe821de910bcea1167b85e660e3891c3d52c6d2000dd1b3de2b33d3d83d90e8ec5d20142d13eeadd1ae92c26ff4620bd52d87a831aad2cd1a'
+ 'aef3011c52203bef1c5b0890048f80af5b8156c2cafd675fcf801f26eda17ee03e67dde22390b2ee46bac9b57003d9287bed3589a17f16dc89bd4f7b9d91102c'
+ '94eb8e2530a0268f4ab41441a6900ebdf7a6d47378b9e2c9a5d2946d01a8a42bc246e74818d44b71ba756d80c8fcd627f775757804d15deb36db12eab2851964'
+ '515955274ebafc6fdce379695b7877906e71c0dfdad1c4c0d6c71e147315ad402541381609d60cd6e14ebfd923942607031de6832e64f96e2de9f5ca01b49357'
+ 'bcf9ff65d2ac6545764258b7b6039a7688fee6c41830661dc2dca9e00bc1bc4aada22c04ef91e58fdc93077bc163bb345cc282bdae325ede2c10bcbbd43ef967')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ## Since adding the Fedora patches I've commented this out, but left it included in the source package in case it's of use later.
+ #patch -Np1 -i "${srcdir}"/gcc45.patch
+
+ ## The below patches are from Fedora, you pulled them out of: pinball-0.3.1-22.fc20.src.rpm
+ ## ( http://redhat.download.fedoraproject.org/pub/fedora-secondary/development/20/source/SRPMS/p/pinball-0.3.1-22.fc20.src.rpm )
+ patch -Np0 -i "${srcdir}"/pinball-0.3.1-cstddef.patch
+ patch -Np1 -i "${srcdir}"/pinball-0.3.1-hiscore.patch
+ patch -Np0 -i "${srcdir}"/pinball-0.3.1-lacomment.patch
+ patch -Np0 -i "${srcdir}"/pinball-0.3.1-strictproto.patch
+ patch -Np1 -i "${srcdir}"/pinball-0.3.1-sys-ltdl.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --disable-sdltest
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/gcc45.patch b/gcc45.patch
new file mode 100644
index 000000000000..966221224423
--- /dev/null
+++ b/gcc45.patch
@@ -0,0 +1,36 @@
+diff -ur pinball-0.3.1/base/Config.cpp pinball-0.3.1_fixed//base/Config.cpp
+--- pinball-0.3.1/base/Config.cpp 2003-11-21 05:59:09.000000000 -0200
++++ pinball-0.3.1_fixed//base/Config.cpp 2010-11-30 19:27:11.952939021 -0200
+@@ -397,8 +397,8 @@
+ }
+
+ ///!+rzr this workaround Full path to relative ones, usefull for windows port
+-bool isAbsolutePath(char const * const argv0 ) ;
+-bool isAbsolutePath(char const * const argv0 )
++bool isAbsolutePath(char * const argv0 ) ;
++bool isAbsolutePath(char * const argv0 )
+ {
+ //EM_COUT(" check root drive c:\\ // absolute path - check for wine ?", 42);
+ bool t = false;
+@@ -415,7 +415,7 @@
+ }
+ /// TODO; make it more robust for stranges paths
+ /// (ie "c:\\d/i//r\like\\\\this/\\/") , wine virtual pc etc
+-void Config::setPaths(char const * const argv0) {
++void Config::setPaths(char * const argv0) {
+ // EM_CERR("+ Config::setPath");
+ //!+rzr : make it work also in relative paths use
+ // and "/long path/quoted/paths/" etc
+Only in pinball-0.3.1_fixed//base: Config.cpp~
+diff -ur pinball-0.3.1/base/Config.h pinball-0.3.1_fixed//base/Config.h
+--- pinball-0.3.1/base/Config.h 2003-11-20 14:46:16.000000000 -0200
++++ pinball-0.3.1_fixed//base/Config.h 2010-11-30 19:28:17.076265440 -0200
+@@ -87,7 +87,7 @@
+ void loadConfig();
+ void setDefault();
+ /// set RELATIVE path according to current work directory of exec
+- void setPaths(char const * const argv0); //!+rzr
++ void setPaths(char * const argv0); //!+rzr
+
+ private:
+ int m_iWidth;
diff --git a/pinball-0.3.1-cstddef.patch b/pinball-0.3.1-cstddef.patch
new file mode 100644
index 000000000000..0be44d1eea09
--- /dev/null
+++ b/pinball-0.3.1-cstddef.patch
@@ -0,0 +1,30 @@
+--- base/Behavior.cpp~ 2003-11-20 10:46:16.000000000 -0600
++++ base/Behavior.cpp 2011-02-09 13:19:13.651559002 -0600
+@@ -6,6 +6,7 @@
+ email : henqvist@excite.com
+ ***************************************************************************/
+
++#include <cstddef>
+ #include "Private.h"
+ #include "Behavior.h"
+ #include "Group.h"
+--- base/BehaviorVisitor.cpp~ 2003-11-20 10:46:16.000000000 -0600
++++ base/BehaviorVisitor.cpp 2011-02-09 13:26:17.561558995 -0600
+@@ -6,6 +6,7 @@
+ email : henqvist@excite.com
+ ***************************************************************************/
+
++#include <cstddef>
+ #include "BehaviorVisitor.h"
+ #include "Behavior.h"
+ #include "Group.h"
+--- base/SignalSender.cpp~ 2003-11-20 10:46:16.000000000 -0600
++++ base/SignalSender.cpp 2011-02-09 13:35:29.151558926 -0600
+@@ -7,6 +7,7 @@
+ ***************************************************************************/
+
+
++#include <cstddef>
+ #include "Private.h"
+ #include "SignalSender.h"
+ #include "Group.h"
diff --git a/pinball-0.3.1-hiscore.patch b/pinball-0.3.1-hiscore.patch
new file mode 100644
index 000000000000..bf4067409779
--- /dev/null
+++ b/pinball-0.3.1-hiscore.patch
@@ -0,0 +1,39 @@
+--- pinball-0.3.1/src/Table.cpp~ 2006-08-03 14:59:16.000000000 +0200
++++ pinball-0.3.1/src/Table.cpp 2006-08-03 14:59:16.000000000 +0200
+@@ -247,14 +247,9 @@
+ // Clear old high scores
+ m_mapHighScores.clear();
+
+- //!rzr+ : fix w32
+- string sFileName = m_sTableName + "/" + HIGH_SCORES_FILENAME;
+-#ifdef RZR_PATHRELATIVE
+- sFileName = string( Config::getInstance()->getExeDir() )
+- +"/"+ m_sTableName +".cfg";
+-#else
+- sFileName = string(EM_HIGHSCORE_DIR) + "/" + sFileName;
+-#endif //!rzr-
++ char *home = getenv("HOME");
++ string sFileName = string(home? home:".") + "/.emilia/" + m_sTableName +
++ ".hiscore";
+
+ ifstream file(sFileName.c_str());
+ if (!file) {
+@@ -308,14 +303,10 @@
+ cerr << "No current table name! (the first time is normal...)" << endl;
+ return false;
+ }
+- //!rzr+ : fix w32
+- string sFileName = m_sTableName + "/" + HIGH_SCORES_FILENAME;
+-#ifdef RZR_PATHRELATIVE
+- sFileName = string( Config::getInstance()->getExeDir() )
+- +"/"+ m_sTableName +".cfg";
+-#else
+- sFileName = string(EM_HIGHSCORE_DIR) + "/" + sFileName;
+-#endif //!rzr-
++
++ char *home = getenv("HOME");
++ string sFileName = string(home? home:".") + "/.emilia/" + m_sTableName +
++ ".hiscore";
+
+ ofstream file(sFileName.c_str());//, ios_base::out | ios_base::trunc);
+ if (!file) {
diff --git a/pinball-0.3.1-lacomment.patch b/pinball-0.3.1-lacomment.patch
new file mode 100644
index 000000000000..60a93bc548fe
--- /dev/null
+++ b/pinball-0.3.1-lacomment.patch
@@ -0,0 +1,22 @@
+--- src/Makefile.in~ 2010-11-15 10:55:51.000000000 -0600
++++ src/Makefile.in 2010-11-15 11:07:27.427255000 -0600
+@@ -505,7 +505,7 @@
+ uninstall-pinincludeHEADERS uninstall-pinlibLIBRARIES
+
+
+-dnl libemilia_pin_la_SOURCES = $(libemilia_pin_a_SOURCES)
++#dnl libemilia_pin_la_SOURCES = $(libemilia_pin_a_SOURCES)
+
+ # !+rzr : This trick workaround a bad generated rule (under Linux mingw32)
+ # src/ litool returns: -L/usr/local//lib /usr/lib/libjpeg.so
+--- test/Makefile.in~ 2010-11-15 11:11:07.000000000 -0600
++++ test/Makefile.in 2010-11-15 11:12:46.119254852 -0600
+@@ -621,7 +621,7 @@
+ mostlyclean-generic mostlyclean-libtool tags uninstall \
+ uninstall-am uninstall-info-am uninstall-testlibLTLIBRARIES
+
+-dnl noinst_PROGRAMS = unittest
++#dnl noinst_PROGRAMS = unittest
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/pinball-0.3.1-strictproto.patch b/pinball-0.3.1-strictproto.patch
new file mode 100644
index 000000000000..89a7fe9fa320
--- /dev/null
+++ b/pinball-0.3.1-strictproto.patch
@@ -0,0 +1,7 @@
+--- base/Config.cpp.orig 2009-03-02 10:46:40.000000000 -0600
++++ base/Config.cpp 2009-03-02 10:46:40.000000000 -0600
+@@ -426,2 +426,2 @@
+- char* ptr=0;
+- char* ptrw = 0;
++ const char* ptr=0;
++ const char* ptrw = 0;
diff --git a/pinball-0.3.1-sys-ltdl.patch b/pinball-0.3.1-sys-ltdl.patch
new file mode 100644
index 000000000000..19ecad5afb6a
--- /dev/null
+++ b/pinball-0.3.1-sys-ltdl.patch
@@ -0,0 +1,152 @@
+--- pinball-0.3.1/Makefile.in~ 2006-08-03 12:18:40.000000000 +0200
++++ pinball-0.3.1/Makefile.in 2006-08-03 12:18:40.000000000 +0200
+@@ -107,7 +107,7 @@
+ install_sh = @install_sh@
+ AUTOMAKE_OPTIONS = gnu
+
+-SUBDIRS = libltdl addon base data src test
++SUBDIRS = addon base data src test
+
+ EXTRA_DIST = bootstrap pinball.spec clean pinball.desktop
+
+--- pinball-0.3.1/src/Makefile.in~ 2006-08-03 12:20:12.000000000 +0200
++++ pinball-0.3.1/src/Makefile.in 2006-08-03 12:20:12.000000000 +0200
+@@ -114,9 +114,9 @@
+
+ pinlib_LIBRARIES = libemilia_pin.a
+
+-INCLUDES = -I../base -I../addon @INCLTDL@
++INCLUDES = -I../base -I../addon
+
+-pinball_LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
++pinball_LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a -lltdl
+ pinball_LDFLAGS = -export-dynamic
+
+ pinball_SOURCES = Pinball.cpp
+--- pinball-0.3.1/src/Makefile.am~ 2006-08-03 12:20:35.000000000 +0200
++++ pinball-0.3.1/src/Makefile.am 2006-08-03 12:20:35.000000000 +0200
+@@ -7,9 +7,9 @@
+
+ pinlib_LIBRARIES = libemilia_pin.a
+
+-INCLUDES = -I../base -I../addon @INCLTDL@
++INCLUDES = -I../base -I../addon
+
+-pinball_LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
++pinball_LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a -lltdl
+ pinball_LDFLAGS = -export-dynamic
+
+ pinball_SOURCES = Pinball.cpp
+--- pinball-0.3.1/Makefile.am~ 2006-08-03 12:18:12.000000000 +0200
++++ pinball-0.3.1/Makefile.am 2006-08-03 12:18:12.000000000 +0200
+@@ -1,6 +1,6 @@
+ AUTOMAKE_OPTIONS = gnu
+
+-SUBDIRS = libltdl addon base data src test
++SUBDIRS = addon base data src test
+
+ EXTRA_DIST = bootstrap pinball.spec clean pinball.desktop
+
+--- pinball-0.3.1/configure.ac~ 2006-08-03 12:17:50.000000000 +0200
++++ pinball-0.3.1/configure.ac 2006-08-03 12:17:50.000000000 +0200
+@@ -14,19 +14,13 @@
+ CFLAGS="-g -W -Wall -O2"
+ CXXFLAGS="-g -W -Wall -O2"
+
+-AC_CONFIG_SUBDIRS(libltdl)
+-
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_LIBTOOL_DLOPEN
+-AC_LIBLTDL_CONVENIENCE
+ AC_PROG_LIBTOOL
+
+-AC_SUBST(INCLTDL)
+-AC_SUBST(LIBLTDL)
+-
+ dnl *******************************************
+ dnl PATHS AND DIRS ****************************
+ dnl data dirs, fuck I hate autoconf, spent 4 hours getting this right, had to
+--- pinball-0.3.1/test/Makefile.in~ 2006-08-03 12:21:11.000000000 +0200
++++ pinball-0.3.1/test/Makefile.in 2006-08-03 12:21:11.000000000 +0200
+@@ -112,8 +112,8 @@
+
+ noinst_PROGRAMS = scale simple light texture load explode collision signal billboard font thread menu joy sound trans math misc varray unittest
+
+-INCLUDES = -I../base -I../addon -I../src @INCLTDL@
+-LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
++INCLUDES = -I../base -I../addon -I../src
++LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a -lltdl
+
+ testlib_LTLIBRARIES = libModuleTest.la
+
+--- pinball-0.3.1/test/Makefile.am~ 2006-08-03 12:20:53.000000000 +0200
++++ pinball-0.3.1/test/Makefile.am 2006-08-03 12:20:53.000000000 +0200
+@@ -6,8 +6,8 @@
+ noinst_PROGRAMS = scale simple light texture load explode collision signal billboard font thread menu joy sound trans math misc varray unittest
+ dnl noinst_PROGRAMS = unittest
+
+-INCLUDES = -I../base -I../addon -I../src @INCLTDL@
+-LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
++INCLUDES = -I../base -I../addon -I../src
++LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a -lltdl
+
+ testlib_LTLIBRARIES = libModuleTest.la
+
+--- pinball-0.3.1/configure~ 2006-08-03 12:16:59.000000000 +0200
++++ pinball-0.3.1/configure 2006-08-03 12:16:59.000000000 +0200
+@@ -431,7 +431,6 @@
+ PACKAGE_STRING='pinball 0.3.1'
+ PACKAGE_BUGREPORT='henqvist@users.sourceforge.net'
+
+-ac_subdirs_all="$ac_subdirs_all libltdl"
+ # Factoring default headers for most tests.
+ ac_includes_default="\
+ #include <stdio.h>
+@@ -469,7 +468,7 @@
+ # include <unistd.h>
+ #endif"
+
+-ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO AMTAR install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM AWK SET_MAKE subdirs CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE CXX CXXFLAGS ac_ct_CXX CXXDEPMODE LN_S ECHO RANLIB ac_ct_RANLIB CPP EGREP LIBTOOL INCLTDL LIBLTDL EM_DATADIR EM_LIBDIR EM_BUILD_ROOT EM_HIGHSCORE_DIR X_CFLAGS X_PRE_LIBS X_LIBS X_EXTRA_LIBS MATHLIB GL_LIBS SDL_CONFIG SDL_CFLAGS SDL_LIBS ALLEGRO_CONFIG ALLEGRO_CFLAGS ALLEGRO_LIBS CPPUNIT_CONFIG CPPUNIT_CFLAGS CPPUNIT_LIBS LIBOBJS LTLIBOBJS'
++ac_subst_vars='SHELL PATH_SEPARATOR PACKAGE_NAME PACKAGE_TARNAME PACKAGE_VERSION PACKAGE_STRING PACKAGE_BUGREPORT exec_prefix prefix program_transform_name bindir sbindir libexecdir datadir sysconfdir sharedstatedir localstatedir libdir includedir oldincludedir infodir mandir build_alias host_alias target_alias DEFS ECHO_C ECHO_N ECHO_T LIBS build build_cpu build_vendor build_os host host_cpu host_vendor host_os target target_cpu target_vendor target_os INSTALL_PROGRAM INSTALL_SCRIPT INSTALL_DATA PACKAGE VERSION ACLOCAL AUTOCONF AUTOMAKE AUTOHEADER MAKEINFO AMTAR install_sh STRIP ac_ct_STRIP INSTALL_STRIP_PROGRAM AWK SET_MAKE subdirs CC CFLAGS LDFLAGS CPPFLAGS ac_ct_CC EXEEXT OBJEXT DEPDIR am__include am__quote AMDEP_TRUE AMDEP_FALSE AMDEPBACKSLASH CCDEPMODE CXX CXXFLAGS ac_ct_CXX CXXDEPMODE LN_S ECHO RANLIB ac_ct_RANLIB CPP EGREP LIBTOOL EM_DATADIR EM_LIBDIR EM_BUILD_ROOT EM_HIGHSCORE_DIR X_CFLAGS X_PRE_LIBS X_LIBS X_EXTRA_LIBS MATHLIB GL_LIBS SDL_CONFIG SDL_CFLAGS SDL_LIBS ALLEGRO_CONFIG ALLEGRO_CFLAGS ALLEGRO_LIBS CPPUNIT_CONFIG CPPUNIT_CFLAGS CPPUNIT_LIBS LIBOBJS LTLIBOBJS'
+ ac_subst_files=''
+
+ # Initialize some variables set by options.
+@@ -1959,7 +1958,6 @@
+
+
+
+-subdirs="$subdirs libltdl"
+
+
+ ac_ext=c
+@@ -3439,18 +3437,6 @@
+ test -z "$INSTALL_DATA" && INSTALL_DATA='${INSTALL} -m 644'
+
+
+- case $enable_ltdl_convenience in
+- no) { { echo "$as_me:$LINENO: error: this package needs a convenience libltdl" >&5
+-echo "$as_me: error: this package needs a convenience libltdl" >&2;}
+- { (exit 1); exit 1; }; } ;;
+- "") enable_ltdl_convenience=yes
+- ac_configure_args="$ac_configure_args --enable-ltdl-convenience" ;;
+- esac
+- LIBLTDL='${top_builddir}/''libltdl'/libltdlc.la
+- LTDLINCL='-I${top_srcdir}/''libltdl'
+- # For backwards non-gettext consistent compatibility...
+- INCLTDL="$LTDLINCL"
+-
+ # Check whether --enable-shared or --disable-shared was given.
+ if test "${enable_shared+set}" = set; then
+ enableval="$enable_shared"
+@@ -11788,8 +11774,6 @@
+ s,@CPP@,$CPP,;t t
+ s,@EGREP@,$EGREP,;t t
+ s,@LIBTOOL@,$LIBTOOL,;t t
+-s,@INCLTDL@,$INCLTDL,;t t
+-s,@LIBLTDL@,$LIBLTDL,;t t
+ s,@EM_DATADIR@,$EM_DATADIR,;t t
+ s,@EM_LIBDIR@,$EM_LIBDIR,;t t
+ s,@EM_BUILD_ROOT@,$EM_BUILD_ROOT,;t t
diff --git a/pinball.install b/pinball.install
new file mode 100644
index 000000000000..e39f87dae836
--- /dev/null
+++ b/pinball.install
@@ -0,0 +1,30 @@
+post_install() {
+ touch var/games/pinball/{professor,tux}/highscores
+ chown root:games var/games/pinball/{professor,tux}/highscores
+ chmod 664 var/games/pinball/{professor,tux}/highscores
+}
+
+pre_upgrade() {
+ chown root:games var/games/pinball/{professor,tux}
+ chmod 775 var/games/pinball/{professor,tux}
+ cp var/games/pinball/professor/highscores var/games/pinball/professor/highscores.bak.pre_upgrade
+ cp var/games/pinball/tux/highscores var/games/pinball/tux/highscores.bak.pre_upgrade
+}
+
+post_upgrade() {
+ if [ -e var/games/pinball/professor/highscores.bak.pre_upgrade ]; then
+ mv var/games/pinball/professor/highscores.bak.pre_upgrade var/games/pinball/professor/highscores
+ fi
+
+ if [ -e var/games/pinball/tux/highscores.bak.pre_upgrade ]; then
+ mv var/games/pinball/tux/highscores.bak.pre_upgrade var/games/pinball/tux/highscores
+ fi
+
+ touch var/games/pinball/professor/highscores
+ chown root:games var/games/pinball/professor/highscores
+ chmod 664 var/games/pinball/professor/highscores
+
+ touch var/games/pinball/tux/highscores
+ chown root:games var/games/pinball/tux/highscores
+ chmod 664 var/games/pinball/tux/highscores
+ }