summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-12 10:17:05 +0800
committerzxp198210052023-09-12 10:17:05 +0800
commit5725c15e785f3667d24607072118dfe35b0caf20 (patch)
treeaf2f90c64dac36be1a85db88222cf0d0a40d919a
parent77d9c786a98da2bc4dfc12176ffd869a0c5eed26 (diff)
downloadaur-5725c15e785f3667d24607072118dfe35b0caf20.tar.gz
fix errors
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
-rw-r--r--dbgate.sh2
3 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9922d6d5df6c..10f3cab35391 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = dbgate-bin
pkgdesc = Database manager for MySQL, PostgreSQL, SQL Server, MongoDB, SQLite and others. Runs under Windows, Linux, Mac or as web application
pkgver = 5.2.6
- pkgrel = 3
+ pkgrel = 4
url = https://dbgate.org/
arch = aarch64
arch = armv7h
arch = x86_64
license = MIT
+ makedepends = asar
depends = bash
- depends = hicolor-icon-theme
depends = electron25
- depends = gcc-libs
- depends = glibc
+ depends = hicolor-icon-theme
provides = dbgate=5.2.6
conflicts = dbgate
- source = LICENSE::https://raw.githubusercontent.com/dbgate/dbgate/master/LICENSE
+ source = LICENSE::https://raw.githubusercontent.com/dbgate/dbgate/v5.2.6/LICENSE
source = dbgate.sh
sha256sums = 4ba7d897a31d45781b6bbc0b87e9a241873d61fff657af2f0c54608f652d235b
- sha256sums = 530c8f6e9e0e9e3655dfefe281f95e831ae0b2c1c5c6fa2caa16cc7081c23767
+ sha256sums = b9185d6ca76cd143d4b74f3f79dfc4dc84c2a760719c32a58ecd891248dff2ec
source_aarch64 = dbgate-5.2.6-aarch64.AppImage::https://github.com/dbgate/dbgate/releases/download/v5.2.6/dbgate-5.2.6-linux_arm64.AppImage
sha256sums_aarch64 = 31f496aba3184e978faa6ad845637b9495f097d9cd0b017b8ee7004ed939350c
source_armv7h = dbgate-5.2.6-armv7h.AppImage::https://github.com/dbgate/dbgate/releases/download/v5.2.6/dbgate-5.2.6-linux_armv7l.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index 1130c519790c..fb50c300e345 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: aulonsal <seraur at aulonsal dot com>
pkgname=dbgate-bin
pkgver=5.2.6
-pkgrel=3
+pkgrel=4
pkgdesc="Database manager for MySQL, PostgreSQL, SQL Server, MongoDB, SQLite and others. Runs under Windows, Linux, Mac or as web application"
arch=('aarch64' 'armv7h' 'x86_64')
url="https://dbgate.org/"
@@ -10,30 +10,33 @@ _githuburl="https://github.com/dbgate/dbgate"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('bash' 'hicolor-icon-theme' 'electron25' 'gcc-libs' 'glibc')
+depends=('bash' 'electron25' 'hicolor-icon-theme')
+makedepends=('asar')
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_arm64.AppImage")
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.AppImage::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_armv7l.AppImage")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-${pkgver}-linux_x86_64.AppImage")
-source=("LICENSE::https://raw.githubusercontent.com/dbgate/dbgate/master/LICENSE"
+source=("LICENSE::https://raw.githubusercontent.com/dbgate/dbgate/v${pkgver}/LICENSE"
"${pkgname%-bin}.sh")
sha256sums=('4ba7d897a31d45781b6bbc0b87e9a241873d61fff657af2f0c54608f652d235b'
- '530c8f6e9e0e9e3655dfefe281f95e831ae0b2c1c5c6fa2caa16cc7081c23767')
+ 'b9185d6ca76cd143d4b74f3f79dfc4dc84c2a760719c32a58ecd891248dff2ec')
sha256sums_aarch64=('31f496aba3184e978faa6ad845637b9495f097d9cd0b017b8ee7004ed939350c')
sha256sums_armv7h=('1729dbb58eb4cbe28d55b97b8a5486c95a5ec9baf3b703cfab450e669cbe957c')
sha256sums_x86_64=('070e7e31a617b8e4f50f9cf7708993a12e8075dfed0f0cbdaff6fb32cbe2c941')
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null
+ asar e "${srcdir}/squashfs-root/resources/app.asar" "${srcdir}/app.asar.unpacked"
+ cp -r "${srcdir}/squashfs-root/resources/app.asar.unpacked" "${srcdir}"
+ asar p "${srcdir}/app.asar.unpacked" "${srcdir}/${pkgname%-bin}.asar"
+ sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
- install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- cp -r "${srcdir}/squashfs-root/resources/"* "${pkgdir}/opt/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.asar" -t "${pkgdir}/opt/${pkgname%-bin}"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512;do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
-t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
done
- sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
- find "${pkgdir}/opt/${pkgname%-bin}" -type d -exec chmod 755 {} \;
} \ No newline at end of file
diff --git a/dbgate.sh b/dbgate.sh
index 0a808e38f21e..7e435a84ea46 100644
--- a/dbgate.sh
+++ b/dbgate.sh
@@ -1,6 +1,6 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron25
-_ASAR="/opt/dbgate/app.asar"
+_ASAR="/opt/dbgate/dbgate.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else