summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2024-04-23 23:31:03 +0200
committerPeter Mattern2024-04-23 23:31:03 +0200
commit578765898242aefc769e21dbe7780b61ad705cd3 (patch)
treefa3a15316a11364bbd063eaaa885daf8e32b048b
parent6d07789c11c7956ab4c28c744761c9bbd5cf3079 (diff)
downloadaur-578765898242aefc769e21dbe7780b61ad705cd3.tar.gz
Miscellaneous updates
* upstream URL (homepage) * license string * dependencies * improve pkgver()
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbee87748daa..b209a1bc8943 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = qps-git
pkgdesc = Qt process manager
- pkgver = 2.0.0.81.g057cf16
+ pkgver = 2.9.0
pkgrel = 1
- url = https://github.com/lxqt/qps
+ url = https://lxqt-project.org
arch = i686
arch = x86_64
- license = GPL
+ license = GPL-2.0-only
makedepends = git
makedepends = cmake
- makedepends = qt5-tools
+ makedepends = qt6-tools
makedepends = lxqt-build-tools-git
- depends = qt5-x11extras
- depends = gtk-update-icon-cache
depends = liblxqt-git
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
provides = qps
conflicts = qps
source = git+https://github.com/lxqt/qps.git
sha256sums = SKIP
pkgname = qps-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 956da4b5cd0d..b55317ae6d0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
_pkgname=qps
pkgname=$_pkgname-git
-pkgver=2.0.0.81.g057cf16
+pkgver=2.9.0
pkgrel=1
pkgdesc='Qt process manager'
arch=('i686' 'x86_64')
-url='https://github.com/lxqt/qps'
-license=('GPL')
-depends=('qt5-x11extras' 'gtk-update-icon-cache' 'liblxqt-git')
-makedepends=('git' 'cmake' 'qt5-tools' 'lxqt-build-tools-git')
+url="https://lxqt-project.org"
+license=("GPL-2.0-only")
+depends=('liblxqt-git' 'hicolor-icon-theme' 'gtk-update-icon-cache')
+makedepends=('git' 'cmake' 'qt6-tools' 'lxqt-build-tools-git')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+https://github.com/lxqt/qps.git")
+source=("git+https://github.com/lxqt/$_pkgname.git")
sha256sums=("SKIP")
pkgver() {
cd $_pkgname
- git describe --always | sed 's:-:.:g'
+ git describe --always | sed "s/-/.r/;s/-/./"
}
build() {