summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorC. N. Hsing2019-02-08 03:22:47 +0800
committerC. N. Hsing2019-02-08 03:22:47 +0800
commit57aa0a165060f46930b35121df9d9cae80485327 (patch)
treeee8b00d9f38fc1f0b50a607fbb9b3e5eaf99ba6a
downloadaur-57aa0a165060f46930b35121df9d9cae80485327.tar.gz
inital
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..004d63579334
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = transmission-web-control-git
+ pkgdesc = a custom web UI for transmission
+ pkgver = 1.6.0.beta2.r31.g50bcc1d
+ pkgrel = 1
+ url = https://github.com/ronggang/transmission-web-control
+ arch = any
+ license = MIT
+ source = git+https://github.com/ronggang/transmission-web-control
+ sha1sums = SKIP
+
+pkgname = transmission-web-control-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..283f0833c682
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=transmission-web-control-git
+pkgver=1.6.0.beta2.r31.g50bcc1d
+pkgrel=1
+pkgdesc='A custom web UI for transmission'
+arch=(any)
+url='https://github.com/ronggang/transmission-web-control'
+license=('MIT')
+source=("git+${url}")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/${pkgname%-*}"
+
+ install -dm755 "$pkgdir"/usr/share/transmission/web/
+ cp -r src/{favicon.ico,index.mobile.html,tr-web-control} "$pkgdir"/usr/share/transmission/web/
+ install -m644 src/index.html "$pkgdir"/usr/share/transmission/web/index.new.html
+ install -pDm644 LICENSE "$pkgdir"/usr/share/licenses/"${pkgname%-*}"/LICENSE
+}