summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-07-09 10:22:04 +0200
committerMaxime Gauduin2015-07-09 10:22:04 +0200
commit57c874d012cc5bb139333ef4ccdca5e55f6b7f43 (patch)
treeb0b0f63184d80dc9ca0c600bdf84b75426466683
downloadaur-57c874d012cc5bb139333ef4ccdca5e55f6b7f43.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--MKPKG9
-rw-r--r--PKGBUILD40
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f3605eb5d8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lib32-unixodbc
+ pkgdesc = ODBC is an open specification for providing application developers with a predictable API with which to access Data Sources
+ pkgver = 2.3.2
+ pkgrel = 1
+ url = http://www.unixodbc.org/
+ arch = x86_64
+ groups = pipelight-libs
+ license = GPL2
+ license = LGPL2.1
+ makedepends = gcc-multilib
+ depends = lib32-libltdl
+ depends = unixodbc
+ source = http://www.unixodbc.org/unixODBC-2.3.2.tar.gz
+ sha256sums = 9c3459742f25df5aa3c10a61429bde51a6d4f11552c03095f1d33d7eb02b5c9a
+
+pkgname = lib32-unixodbc
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..c55d7e68b27a
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,9 @@
+arch=('x86_64')
+pkgname=('lib32-unixodbc')
+
+build () {
+ shift
+ ionice -c 3 chrt -b 0 sudo multilib-build -- $*
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e5640537e43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: AndyRTR <andyrtr@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=lib32-unixodbc
+pkgver=2.3.2
+pkgrel=1
+pkgdesc='ODBC is an open specification for providing application developers with a predictable API with which to access Data Sources'
+arch=('x86_64')
+url='http://www.unixodbc.org/'
+license=('GPL2' 'LGPL2.1')
+depends=('lib32-libltdl' 'unixodbc')
+makedepends=('gcc-multilib')
+groups=('pipelight-libs')
+source=("http://www.unixodbc.org/unixODBC-$pkgver.tar.gz")
+sha256sums=('9c3459742f25df5aa3c10a61429bde51a6d4f11552c03095f1d33d7eb02b5c9a')
+
+build() {
+ cd unixODBC-${pkgver}
+
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH='/usr/lib32/pkgconfig'
+
+ ./configure \
+ --prefix='/usr' \
+ --libdir='/usr/lib32' \
+ --sysconfdir='/etc'
+ make
+}
+
+package() {
+ cd unixODBC-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/{etc,usr/{bin,include,share}}
+}
+
+# vim: ts=2 sw=2 et: