summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyril Levis2020-05-23 18:07:22 +0200
committerCyril Levis2020-05-23 18:07:22 +0200
commit57f620f94660d89c3fc00fc482e2e188881b4750 (patch)
tree7e4a268946b0c21cd8bc612ccebb2028346dbeb5
downloadaur-57f620f94660d89c3fc00fc482e2e188881b4750.tar.gz
Initial upload: wluma-als-emulator-git master-1
Deleted package: fake-light-sensor-git
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4eff4290923
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wluma-als-emulator-git
+ pkgdesc = Light sensor emulator for wluma, write lux from webcam or time based to a file
+ pkgver = master
+ pkgrel = 1
+ url = https://github.com/cyrinux/wluma-als-emulator
+ arch = any
+ license = MIT
+ makedepends = git
+ optdepends = wluma
+ optdepends = python-pillow
+ optdepends = ffmpeg
+ provides = wluma-als-emulator
+ conflicts = fake-light-sensor
+ conflicts = fake-light-sensor-git
+ source = git://github.com/cyrinux/wluma-als-emulator
+ md5sums = SKIP
+
+pkgname = wluma-als-emulator-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..309b4c0f0f01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Cyrinux <pkgbuilds AT levis DOT name>
+
+pkgname=wluma-als-emulator-git
+_gitname=wluma-als-emulator
+pkgver=master
+pkgrel=1
+pkgdesc="Light sensor emulator for wluma, write lux from webcam or time based to a file"
+license=(MIT)
+url=https://github.com/cyrinux/wluma-als-emulator
+depends=()
+optdepends=('wluma' 'python-pillow' 'ffmpeg')
+arch=(any)
+makedepends=('git')
+conflicts=('fake-light-sensor' 'fake-light-sensor-git')
+provides=('wluma-als-emulator')
+source=('git://github.com/cyrinux/wluma-als-emulator')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/wluma-als-emulator"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/wluma-als-emulator"
+ install -D -m0755 \
+ "${srcdir}/wluma-als-emulator/wluma-als-emulator" \
+ "$pkgdir/usr/bin/wluma-als-emulator"
+}