summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElaina Martineau2019-07-29 00:00:25 -0600
committerElaina Martineau2019-07-29 00:00:25 -0600
commit58072b2c5050bc96533ba9f5ba74a1ae5c4a4eb1 (patch)
tree8c55294ab6ed07a2d668acdb42cf2fec245f6552
parentd8ca8f8dea5ddf08ac8a6905a744b4ca13d2f34b (diff)
downloadaur-58072b2c5050bc96533ba9f5ba74a1ae5c4a4eb1.tar.gz
Update to v108
-rwxr-xr-xPKGBUILD10
-rw-r--r--package.patch12
2 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd9efaa61416..ec656532b5f7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Elaina Martineau <elainamartineau@gmail.com>
pkgname=bsnes
-pkgver=107.1
+pkgver=108
pkgrel=1
pkgdesc='Super Nintendo emulator focusing on performance, features, and ease of use.'
arch=('x86_64')
@@ -10,8 +10,8 @@ license=('GPL3')
depends=('libpulse' 'gtksourceview2' 'libxv' 'libao' 'openal' 'sdl2')
conflicts=('bsnes-classic' 'bsnes-plus')
source=("https://download.byuu.org/${pkgname}_v${pkgver//./r}-source.7z" 'package.patch')
-sha256sums=('8649491111ecf257daec4637d7c238ebed534860a16bcfa139d7bca4c2629fbf'
- 'b578fba0dd5be5a93b0272704a60fa81c0bb524f9b9894b058c1223927d934d0')
+sha256sums=('49c560b8438d0ea3942b1cd90ac3d4b5a33074eca77a0b24a7af463e87187bec'
+ 'e800849a4e6c9b431578c2c55bfaab7b0619629ba34bd97f38bae64d5f2412d6')
prepare() {
cd "${pkgname}_v${pkgver//./r}-source"
@@ -22,11 +22,11 @@ prepare() {
build() {
cd "${pkgname}_v${pkgver//./r}-source"
- make -C higan
+ make -C bsnes
}
package() {
cd "${pkgname}_v${pkgver//./r}-source"
- make -C higan prefix="${pkgdir}/usr" install
+ make -C bsnes prefix="${pkgdir}/usr" install
}
diff --git a/package.patch b/package.patch
index 234d8925bae3..8512d3fd1f22 100644
--- a/package.patch
+++ b/package.patch
@@ -1,6 +1,6 @@
-diff --unified --recursive bsnes_v107-source.orig/higan/GNUmakefile bsnes_v107-source.new/higan/GNUmakefile
---- bsnes_v107-source.orig/higan/GNUmakefile 2019-03-10 01:42:30.163599022 -0700
-+++ bsnes_v107-source.new/higan/GNUmakefile 2019-03-10 01:45:20.179375447 -0700
+diff --unified --recursive bsnes_v108-source.orig/bsnes/GNUmakefile bsnes_v108-source.new/bsnes/GNUmakefile
+--- bsnes_v108-source.orig/bsnes/GNUmakefile 2019-03-10 01:42:30.163599022 -0700
++++ bsnes_v108-source.new/bsnes/GNUmakefile 2019-03-10 01:45:20.179375447 -0700
@@ -1,6 +1,9 @@
+flags = $(CFLAGS)
+options = $(LDFLAGS)
@@ -13,9 +13,9 @@ diff --unified --recursive bsnes_v107-source.orig/higan/GNUmakefile bsnes_v107-s
flags += -I. -I..
-diff --unified --recursive bsnes_v107-source.orig/higan/target-bsnes/GNUmakefile bsnes_v107-source.new/higan/target-bsnes/GNUmakefile
---- bsnes_v107-source.orig/higan/target-bsnes/GNUmakefile 2019-03-10 01:51:07.601683406 -0700
-+++ bsnes_v107-source.new/higan/target-bsnes/GNUmakefile 2019-03-10 01:52:00.013706440 -0700
+diff --unified --recursive bsnes_v108-source.orig/bsnes/target-bsnes/GNUmakefile bsnes_v108-source.new/bsnes/target-bsnes/GNUmakefile
+--- bsnes_v108-source.orig/bsnes/target-bsnes/GNUmakefile 2019-03-10 01:51:07.601683406 -0700
++++ bsnes_v108-source.new/bsnes/target-bsnes/GNUmakefile 2019-03-10 01:52:00.013706440 -0700
@@ -34,9 +34,7 @@
verbose: hiro.verbose ruby.verbose nall.verbose all;