summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2015-07-11 21:15:43 +0300
committersurefire2015-07-11 21:15:43 +0300
commit582f459acbadbf839aae65a43eb125ddde7eeb20 (patch)
tree401d9173e99c2a67bc6f8e8f31370f23056b20ae
downloadaur-582f459acbadbf839aae65a43eb125ddde7eeb20.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD50
-rw-r--r--ddccontrol.install13
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb541e19e69a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ddccontrol-git
+ pkgdesc = Control your monitor by software using the DDC/CI protocol.
+ pkgver = 20140105.r9d89d8c
+ pkgrel = 1
+ url = https://github.com/ddccontrol/ddccontrol
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = intltool
+ depends = pciutils
+ depends = libxml2
+ depends = ddccontrol-db-git
+ provides = ddccontrol
+ conflicts = ddccontrol
+ options = !libtool
+ source = git+https://github.com/ddccontrol/ddccontrol.git
+ md5sums = SKIP
+
+pkgname = ddccontrol-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e52860c900d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: kfgz <kfgz at interia pl>
+# Contributor: Hubert CzobodziЕ„ski <hcz at onet dot eu>
+# Contributor: Nathan Owe <ndowens dot aur at gmail dot com>
+
+pkgname=ddccontrol-git
+_pkgname=ddccontrol
+pkgver=20140105.r9d89d8c
+pkgrel=1
+pkgdesc="Control your monitor by software using the DDC/CI protocol."
+arch=('i686' 'x86_64')
+url="https://github.com/ddccontrol/ddccontrol"
+license=('GPL')
+depends=('pciutils' 'libxml2' 'ddccontrol-db-git')
+makedepends=('git' 'intltool')
+provides=('ddccontrol')
+conflicts=('ddccontrol')
+source=(git+https://github.com/ddccontrol/ddccontrol.git)
+options=('!libtool')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ _gitver="$(git show -s --format="%ci %h" 2> /dev/null)"
+ _gitver="${_gitver//[^[:alnum:][:space:]]/}"
+
+ echo "${_gitver%% *}.r${_gitver##* }"
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ # PKGBUILD should be non-interactive...
+ sed -e 's:read dummy < /dev/tty::' "$(which gettextize)" > gettextize
+ chmod +x gettextize
+
+ sed -e 's:^gettextize :./gettextize :' -i autogen.sh
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="${pkgdir}" install
+ #chmod 755 "${pkgdir}"/usr/bin/ddcpci
+}
diff --git a/ddccontrol.install b/ddccontrol.install
new file mode 100644
index 000000000000..4ef7e17e81c6
--- /dev/null
+++ b/ddccontrol.install
@@ -0,0 +1,13 @@
+post_install() {
+
+echo
+echo "Add 'i2c-dev' module load: echo \"i2c-dev\" > /etc/modules-load.d/90-i2c.conf"
+echo "Or"
+echo "Load manual modprobe i2c-dev"
+echo
+echo "Start: sudo ddccontrol -p"
+echo "Or"
+echo "kdesu gddccontrol"
+echo "gksu gddccontrol"
+
+}