summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2016-11-15 16:24:16 +0100
committerLuca Weiss2016-11-15 16:24:16 +0100
commit5896f7ef6dba06c17712c0fabc822f44a5256759 (patch)
treef1f3f619d76b6d1e96599a95519970f07f827927
downloadaur-5896f7ef6dba06c17712c0fabc822f44a5256759.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1fea6cb0027
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Nov 15 15:24:11 UTC 2016
+pkgbase = kde1-kdeutils
+ pkgdesc = Historical copy of the utility applications module of KDE 1, adapted to compile on modern systems (circa. 2016)
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = https://github.com/KDE/kde1-kdeutils
+ arch = i686
+ arch = x86_64
+ groups = kde1
+ license = GPL2
+ makedepends = cmake
+ depends = qt1
+ depends = kde1-kdelibs
+ source = https://github.com/KDE/kde1-kdeutils/archive/1c14d5cdf59803a8f41165e296f37837e102696d.zip
+ sha256sums = a3d6fa09e6b2c23215782611726f6aeea6b8fb6001cae22d0add3f697be9a557
+
+pkgname = kde1-kdeutils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a88d90d991b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+
+pkgname=kde1-kdeutils
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Historical copy of the utility applications module of KDE 1, adapted to compile on modern systems (circa. 2016)"
+arch=('i686' 'x86_64')
+url="https://github.com/KDE/kde1-kdeutils"
+license=("GPL2")
+groups=("kde1")
+depends=("qt1" "kde1-kdelibs")
+makedepends=("cmake")
+_commit="1c14d5cdf59803a8f41165e296f37837e102696d"
+source=("https://github.com/KDE/$pkgname/archive/$_commit.zip")
+sha256sums=('a3d6fa09e6b2c23215782611726f6aeea6b8fb6001cae22d0add3f697be9a557')
+
+#prepare() {
+# cd $srcdir/$pkgname-$_commit
+# patch -p1 kmail/CMakeLists.txt < $srcdir/kmail_cmake.diff
+#}
+
+build() {
+ cd $srcdir/$pkgname-$_commit
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX='/usr' -DCMAKE_LIBRARY_PATH='/opt/kde1/lib'
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$_commit
+ cd build
+ make DESTDIR="$pkgdir/" install
+ cd ..
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/COPYING
+}
+
+# vim:set ts=2 sw=2 et: