summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArchadept2015-06-22 16:52:41 +0200
committerArchadept2015-06-22 16:52:41 +0200
commit58a2573ac1902b490e692e6fb38e375d96cf313a (patch)
tree0ef6d700bf05edf047053f75eac67e6ad422d746
downloadaur-58a2573ac1902b490e692e6fb38e375d96cf313a.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD43
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a46500f41483
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hunspell-la
+ pkgdesc = Latin dictionary for Hunspell
+ pkgver = 20130331
+ pkgrel = 1
+ url = http://extensions.libreoffice.org/extension-center/latin-spelling-and-hyphenation-dictionaries
+ arch = any
+ license = GPL
+ optdepends = hunspell: the spell checking libraries and apps
+ source = http://extensions.libreoffice.org/extension-center/latin-spelling-and-hyphenation-dictionaries/pscreleasefolder.2011-11-05.0070960452/2013.03.31/dict-la_2013-03-31.oxt
+ md5sums = 46674c8e9985b97e3f71555ed83a90cd
+
+pkgname = hunspell-la
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d41285c4b10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Archadept
+# Revision: 2013-10-18
+
+pkgname=hunspell-la
+pkgver=20130331
+pkgrel=1
+pkgdesc='Latin dictionary for Hunspell'
+arch=('any')
+url="http://extensions.libreoffice.org/extension-center/latin-spelling-and-hyphenation-dictionaries"
+license=('GPL')
+optdepends=('hunspell: the spell checking libraries and apps')
+source=('http://extensions.libreoffice.org/extension-center/latin-spelling-and-hyphenation-dictionaries/pscreleasefolder.2011-11-05.0070960452/2013.03.31/dict-la_2013-03-31.oxt')
+md5sums=('46674c8e9985b97e3f71555ed83a90cd')
+
+package() {
+ cd "${srcdir}/la"
+
+ install -dm755 ${pkgdir}/usr/share/hunspell
+ install -m644 la.dic ${pkgdir}/usr/share/hunspell
+ install -m644 la.aff ${pkgdir}/usr/share/hunspell
+
+ # UTF-8
+ conv='iconv -f iso8859-1 -t utf-8'
+ $conv la.dic > la_LA.dic
+ $conv la.aff | sed '1s/SET ISO8859-1/SET UTF-8/' > la_LA.aff
+ install -m644 la_LA.dic ${pkgdir}/usr/share/hunspell/
+ install -m644 la_LA.aff ${pkgdir}/usr/share/hunspell/
+
+ rm ${pkgdir}/usr/share/hunspell/la.dic
+ rm ${pkgdir}/usr/share/hunspell/la.aff
+
+ # symlinks
+ install -dm755 ${pkgdir}/usr/share/myspell/dicts
+ pushd ${pkgdir}/usr/share/myspell/dicts
+ for file in ${pkgdir}/usr/share/hunspell/*; do
+ ln -sv /usr/share/hunspell/$(basename ${file}) .
+ done
+ popd
+
+ # docs
+ install -dm755 ${pkgdir}/usr/share/doc/${pkgname}
+ install -m644 README_la.txt $pkgdir/usr/share/doc/${pkgname}/README_la.txt
+}