summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthriqon2015-09-10 08:27:45 +0200
committerthriqon2015-09-10 08:27:45 +0200
commit58a3602e04217de4b537e46993abe7d4e158fdef (patch)
tree773efce99d3a716d6be223d10f25e0862948f2d7
downloadaur-58a3602e04217de4b537e46993abe7d4e158fdef.tar.gz
initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f02c038856c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gpp
+ pkgdesc = A general-purpose preprocessor with customizable syntax, suitable for a wide range of preprocessing tasks
+ pkgver = 2.24
+ pkgrel = 1
+ url = http://en.nothingisreal.com/wiki/GPP
+ arch = any
+ license = GPL
+ makedepends = devel-tools
+ provides = gpp
+ source = http://files.nothingisreal.com/software/gpp/gpp-2.24.tar.bz2
+ source = http://files.nothingisreal.com/software/gpp/gpp-2.24.tar.bz2.sig
+ md5sums = f04c2a23312ab3d0c462c7972d1c6aa6
+ md5sums = SKIP
+
+pkgname = gpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f0529db88f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jonas Weber <contact@jonasw.de>
+pkgname=gpp
+pkgver=2.24
+pkgrel=1
+pkgdesc="A general-purpose preprocessor with customizable syntax, suitable for a wide range of preprocessing tasks"
+arch=('any')
+url="http://en.nothingisreal.com/wiki/GPP"
+license=('GPL')
+makedepends=('devel-tools')
+provides=('gpp')
+source=(
+"http://files.nothingisreal.com/software/$pkgname/$pkgname-${pkgver}.tar.bz2"
+"http://files.nothingisreal.com/software/$pkgname/$pkgname-${pkgver}.tar.bz2.sig"
+)
+md5sums=('f04c2a23312ab3d0c462c7972d1c6aa6'
+ 'SKIP')
+validpgpkeys=("28F47A15AB82C216D278DEB92B119C3AEFBF4915")
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}