summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilhelm Schuster2016-03-21 13:02:41 +0100
committerWilhelm Schuster2016-03-21 13:02:41 +0100
commit58c1223b4d85a0c65ec13dac09283beb6153035e (patch)
tree33929be33487a8ee77b96c97591ed714cccd13fb
downloadaur-58c1223b4d85a0c65ec13dac09283beb6153035e.tar.gz
Initial import
Taken from https://github.com/aur-archive/fizmo - update to fizmo-0.7.10 - update to sdl2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f11b1c86546
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fizmo
+ pkgdesc = A Z-Machine interpreter supporting unicode, sound, blorbfile and more.
+ pkgver = 0.7.10
+ pkgrel = 1
+ url = https://christoph-ender.de/fizmo/
+ arch = i686
+ arch = x86_64
+ groups = inform
+ license = BSD
+ depends = libxml2
+ depends = libsndfile
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = sdl2
+ source = https://christoph-ender.de/fizmo/source/fizmo-0.7.10.tar.gz
+ sha256sums = 0e3561492ece58ff60eba768f3b2cfa943ba111736b0f63b775e3face590462b
+
+pkgname = fizmo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4f5e19623db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer Wilhelm Schuster <wilhelm [aT] wilhelm [.] re>
+# Contributor: AlexanderR <alexander r at gmx com>
+# Contributor: Eric Forgeot < http://ifiction.free.fr >
+pkgname=fizmo
+pkgver=0.7.10
+pkgrel=1
+pkgdesc="A Z-Machine interpreter supporting unicode, sound, blorbfile and more."
+arch=('i686' 'x86_64')
+url="https://christoph-ender.de/fizmo/"
+license=('BSD')
+depends=('libxml2' 'libsndfile' 'libjpeg-turbo' 'libpng' 'sdl2')
+groups=('inform')
+source=("https://christoph-ender.de/fizmo/source/$pkgname-$pkgver.tar.gz")
+sha256sums=('0e3561492ece58ff60eba768f3b2cfa943ba111736b0f63b775e3face590462b')
+
+build() {
+ cd $pkgname-$pkgver
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYRIGHT.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+