summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-07-06 18:55:19 -0400
committerTony Lambiris2018-07-06 18:55:19 -0400
commit58c9d22f9d9110de7bf2d7e9c4db7a60bc256222 (patch)
treefba4177d85e58aa46934831189c32266d2f11947
parent46ffac55544c48845027e14f48541fcb2e7deb2d (diff)
downloadaur-58c9d22f9d9110de7bf2d7e9c4db7a60bc256222.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--arch-linux.patch46
3 files changed, 47 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc46962b2fb3..030dba21f2f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = osquery-git
pkgdesc = SQL powered operating system instrumentation, monitoring, and analytics.
- pkgver = 3.2.6.r14.gdeff17a8e
+ pkgver = 3.2.9.r6.g6b7ff81ad
pkgrel = 1
url = https://osquery.io
arch = i686
@@ -49,18 +49,20 @@ pkgbase = osquery-git
makedepends = boost-libs>=1.65.1
makedepends = libc++
makedepends = cppcheck
+ makedepends = ssdeep
depends = wget
depends = unzip
options = !strip
+ options = !ccache
backup = etc/osquery/osquery.conf
- source = osquery-git::git+https://github.com/facebook/osquery#commit=deff17a8e7d0ad136d1532815ce5d5f0eeb014ad
+ source = osquery-git::git+https://github.com/facebook/osquery#commit=6b7ff81ad8041abf90d974f4025b71a24945d36a
source = osqueryd.conf.d
source = osqueryd.service
source = arch-linux.patch
sha256sums = SKIP
sha256sums = ee15a171f114f47a326d236a7d03a07cc3e711016e9a5039638e6137f63e87ec
sha256sums = 82611f3296d1d5b68d2cb32200c95a9ae3469dc5a9696643b69e89a5b9798a72
- sha256sums = c2d4b7e5e85cef135af82ca627f0c05e40ef5e2ffb9e128f01caacd8665c6c15
+ sha256sums = ab8fb189578bc819d8f28bff4308613355a7641eabd7055757fcfcfd351b6043
pkgname = osquery-git
diff --git a/PKGBUILD b/PKGBUILD
index a0d0cd6e5941..c4485ff9a9d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=osquery-git
-pkgver=3.2.6.r14.gdeff17a8e
+pkgver=3.2.9.r6.g6b7ff81ad
pkgrel=1
pkgdesc="SQL powered operating system instrumentation, monitoring, and analytics."
arch=('i686' 'x86_64')
@@ -15,11 +15,12 @@ makedepends=('asio' 'audit' 'aws-sdk-cpp-git' 'git' 'clang' 'benchmark'
'python-jinja' 'python-psutil' 'python-pexpect' 'rocksdb-lite'
'gtest' 'gmock' 'lldpd' 'lld' 'zstd' 'rapidjson' 'apt' 'dpkg'
'rpm-org' 'python2-jinja' 'librdkafka-git' 'augeas>=1.9.0'
- 'boost>=1.65.1' 'boost-libs>=1.65.1' 'libc++' 'cppcheck')
+ 'boost>=1.65.1' 'boost-libs>=1.65.1' 'libc++' 'cppcheck'
+ 'ssdeep')
conflicts=()
backup=('etc/osquery/osquery.conf')
-options=(!strip)
-_gitcommit='deff17a8e7d0ad136d1532815ce5d5f0eeb014ad'
+options=(!strip !ccache)
+_gitcommit='6b7ff81ad8041abf90d974f4025b71a24945d36a'
#source=("${pkgname}::git+https://github.com/facebook/osquery"
source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit}"
"osqueryd.conf.d"
@@ -28,7 +29,7 @@ source=("${pkgname}::git+https://github.com/facebook/osquery#commit=${_gitcommit
sha256sums=('SKIP'
'ee15a171f114f47a326d236a7d03a07cc3e711016e9a5039638e6137f63e87ec'
'82611f3296d1d5b68d2cb32200c95a9ae3469dc5a9696643b69e89a5b9798a72'
- 'c2d4b7e5e85cef135af82ca627f0c05e40ef5e2ffb9e128f01caacd8665c6c15')
+ 'ab8fb189578bc819d8f28bff4308613355a7641eabd7055757fcfcfd351b6043')
#pkgver() {
# cd ${pkgname}
@@ -62,7 +63,9 @@ build() {
#SQLITE_DEBUG=True # Enable SQLite query debugging (very verbose!)
#export SKIP_TESTS=True SKIP_BENCHMARKS=True
- export CC=/usr/bin/gcc CXX=/usr/bin/g++
+ export CC="/usr/bin/gcc"
+ export CXX="/usr/bin/g++"
+ export SKIP_TESTS=True SKIP_BENCHMARKS=True
[[ -z $DEBUG ]] || unset DEBUG
cmake -Wno-dev \
diff --git a/arch-linux.patch b/arch-linux.patch
index 935bcf1c9b3f..634c914f5418 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -37,19 +37,6 @@ index 47ff957d..ab679b5f 100644
"--commit" "master" "-f" "--style=file"
ANALYSIS := ${SOURCE_DIR}/tools/analysis
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 4444a9a2..b9c2640d 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -393,6 +393,8 @@ endif()
-
- if(APPLE)
- LOG_PLATFORM("OS X")
-+elseif(OSQUERY_BUILD_PLATFORM STREQUAL "arch")
-+ LOG_PLATFORM("Arch Linux")
- elseif(OSQUERY_BUILD_PLATFORM STREQUAL "debian")
- LOG_PLATFORM("Debian")
- elseif(OSQUERY_BUILD_PLATFORM STREQUAL "ubuntu")
diff --git a/osquery/tables/CMakeLists.txt b/osquery/tables/CMakeLists.txt
index 8efb6202..7f9d64aa 100644
--- a/osquery/tables/CMakeLists.txt
@@ -66,3 +53,36 @@ index 8efb6202..7f9d64aa 100644
ADD_OSQUERY_LINK_ADDITIONAL("gcrypt gpg-error")
ADD_OSQUERY_LINK_ADDITIONAL("blkid")
ADD_OSQUERY_LINK_ADDITIONAL("ip4tc")
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1c067c938..70f98f4b7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -327,7 +327,6 @@ if (POSIX)
+ # To be safe, only include them when building 'release' outputs.
+ add_compile_options(
+ "$<$<CONFIG:RELEASE>:-g>"
+- "$<$<CONFIG:RELEASE>:-fno-limit-debug-info>"
+ "$<$<CONFIG:RELEASE>:-fPIE>"
+ "$<$<CONFIG:RELEASE>:-fpie>"
+ "$<$<CONFIG:RELEASE>:-fPIC>"
+@@ -546,6 +545,8 @@ endif()
+
+ if(APPLE)
+ LOG_PLATFORM("OS X")
++elseif(OSQUERY_BUILD_PLATFORM STREQUAL "arch")
++ LOG_PLATFORM("Arch Linux")
+ elseif(OSQUERY_BUILD_PLATFORM STREQUAL "debian")
+ LOG_PLATFORM("Debian")
+ elseif(OSQUERY_BUILD_PLATFORM STREQUAL "ubuntu")
+diff --git a/osquery/CMakeLists.txt b/osquery/CMakeLists.txt
+index c5f644c45..7510a6e38 100644
+--- a/osquery/CMakeLists.txt
++++ b/osquery/CMakeLists.txt
+@@ -36,7 +36,6 @@ set(OSQUERY_TABLES_TESTS "")
+ # Add all and extra for osquery code.
+ if(CLANG AND POSIX)
+ add_compile_options(
+- -Wall
+ -Wextra
+ -pedantic
+ -Wuseless-cast