summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZach Jaggi2015-06-27 13:02:58 -0400
committerZach Jaggi2015-06-27 13:02:58 -0400
commit58d9f3920a1e64714dc803f5f18d41f2004bd9ed (patch)
tree7a2b2a10c741904c80f0987bf1ccced864a31aad
downloadaur-58d9f3920a1e64714dc803f5f18d41f2004bd9ed.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
-rw-r--r--alsoftrc9
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..789a598283b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = openal-hrtf
+ pkgdesc = Enable binaural audio globally in 3d applications
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://wiki.archlinux.org/index.php/Gaming
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = openal>=1.14
+ noextract = data02.tgz
+ source = http://kcat.strangesoft.net/openal-releases/openal-soft-1.15.1.tar.bz2
+ source = http://www.sp.m.is.nagoya-u.ac.jp/HRTF/archive/data02.tgz
+ source = alsoftrc
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = openal-hrtf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d09bf81312c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Zach Jaggi <feilen1000@gmail.com>
+
+pkgname=openal-hrtf
+pkgver=1.0
+pkgrel=1
+_oalversion=1.15.1
+arch=('i686' 'x86_64')
+license=('LGPL')
+pkgdesc="Enable binaural audio globally in 3d applications"
+depends=('openal>=1.14')
+url="https://wiki.archlinux.org/index.php/Gaming"
+source=("http://kcat.strangesoft.net/openal-releases/openal-soft-$_oalversion.tar.bz2"
+ 'http://www.sp.m.is.nagoya-u.ac.jp/HRTF/archive/data02.tgz'
+ 'alsoftrc')
+noextract=('data02.tgz')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ cd $srcdir
+ mkdir -p hrtfs CIAIR
+ tar -xf data02.tgz -C CIAIR
+}
+
+build() {
+ for hrtftable in CIAIR; do
+ cd $srcdir/$hrtftable
+ makehrtf -m -r=44100 -i="$srcdir/openal-soft-$_oalversion/utils/$hrtftable.def" -o=$srcdir/hrtfs/$hrtftable-%r.mhr
+ makehrtf -m -r=48000 -i="$srcdir/openal-soft-$_oalversion/utils/$hrtftable.def" -o=$srcdir/hrtfs/$hrtftable-%r.mhr
+ done
+}
+
+package() {
+
+ install -m644 -D $srcdir/alsoftrc $pkgdir/etc/openal/alsoft.conf
+
+ cd $srcdir/hrtfs
+ for hrtftable in CIAIR; do
+ install -m644 -D ./$hrtftable-44100.mhr $pkgdir/usr/share/openal/hrtfs/$hrtftable-44100.mhr
+ install -m644 -D ./$hrtftable-48000.mhr $pkgdir/usr/share/openal/hrtfs/$hrtftable-48000.mhr
+ done
+
+}
diff --git a/alsoftrc b/alsoftrc
new file mode 100644
index 000000000000..16562b772e54
--- /dev/null
+++ b/alsoftrc
@@ -0,0 +1,9 @@
+# This line enables HRTF and is the bare minimum for using it. Note that if you
+# are not using a sample rate of 44100Hz HRTF will be disabled.
+hrtf = true
+
+# Below are some alternate tables to use with HRTF, uncomment to use them. They
+# the '%r' variable and automatically select sample rate from common
+# pre-generated tables.
+
+# hrtf_tables = "/usr/share/openal/hrtfs/CIAIR-%r.mhr"