summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2017-08-03 00:16:47 +0200
committerFabioLolix2017-08-03 00:16:47 +0200
commit58ebf3df3163cbf3b046a602cb3a3d113c434bcc (patch)
tree67635ff731c92ef0da6f00c4348d86a61e1213f8
parent38f5fc898238bf7a6fb0babc36d429e7e7a8f8e3 (diff)
downloadaur-58ebf3df3163cbf3b046a602cb3a3d113c434bcc.tar.gz
update version to 20170516
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--trace_sched_build_fix.diff12
3 files changed, 9 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 443f6690c440..8b45879b5f7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Aug 19 21:52:22 UTC 2016
pkgbase = linux-test-project
pkgdesc = A collection of tools for testing the Linux kernel and related features
- pkgver = 20160510
+ pkgver = 20170516
pkgrel = 1
url = http://linux-test-project.github.io/
arch = i686
@@ -14,10 +12,8 @@ pkgbase = linux-test-project
depends = libcap
depends = libtirpc
depends = python2
- source = https://github.com/linux-test-project/ltp/releases/download/20160510/ltp-full-20160510.tar.bz2
- source = trace_sched_build_fix.diff
- md5sums = baa738d00b53d734c0515b2979a9577e
- md5sums = 852a73b5614df7ab6dbf6293136512de
+ source = https://github.com/linux-test-project/ltp/releases/download/20170516/ltp-full-20170516.tar.bz2
+ md5sums = 12e2d693e73acbfe7e04a7be176a26ff
pkgname = linux-test-project
diff --git a/PKGBUILD b/PKGBUILD
index 8c97dd3f3477..7701be683102 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,19 @@
-# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+
pkgname=linux-test-project
-pkgver=20160510
+pkgver=20170516
pkgrel=1
pkgdesc="A collection of tools for testing the Linux kernel and related features"
arch=('i686' 'x86_64')
license=('GPL2')
url="http://linux-test-project.github.io/"
depends=('acl' 'bash' 'gawk' 'libcap' 'libtirpc' 'python2')
-source=("https://github.com/linux-test-project/ltp/releases/download/$pkgver/ltp-full-$pkgver.tar.bz2"
- "trace_sched_build_fix.diff")
-md5sums=('baa738d00b53d734c0515b2979a9577e'
- '852a73b5614df7ab6dbf6293136512de')
+source=("https://github.com/linux-test-project/ltp/releases/download/$pkgver/ltp-full-$pkgver.tar.bz2")
+md5sums=('12e2d693e73acbfe7e04a7be176a26ff')
prepare() {
cd "$srcdir/ltp-full-$pkgver"
-
- # fix compilation
- patch -Np1 < "$srcdir/trace_sched_build_fix.diff"
- # fix python scripts
find . -type f -exec sed -i 's|^#!.*python$|#!/usr/bin/env python2|' '{}' ';'
}
diff --git a/trace_sched_build_fix.diff b/trace_sched_build_fix.diff
deleted file mode 100644
index b90006dded8d..000000000000
--- a/trace_sched_build_fix.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rup ltp-full-20160510/testcases/kernel/sched/tool/trace_sched.c ltp-full-20160510.new/testcases/kernel/sched/tool/trace_sched.c
---- ltp-full-20160510/testcases/kernel/sched/tool/trace_sched.c 2016-05-10 14:29:54.000000000 +0200
-+++ ltp-full-20160510.new/testcases/kernel/sched/tool/trace_sched.c 2016-08-19 22:11:24.689699756 +0200
-@@ -422,7 +422,7 @@ int main(int argc, /* number of input p
- if (status == (thread_sched_t *) - 1) {
- fprintf(stderr,
- "thread [%d] - process exited with errors %d\n",
-- thrd_ndx, WEXITSTATUS(status));
-+ thrd_ndx, WEXITSTATUS((int)status));
- exit(-1);
- } else {
- exp_prio[thrd_ndx] = status->exp_prio;