summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2020-12-28 19:29:35 +0100
committerMassimiliano Torromeo2020-12-28 19:29:35 +0100
commit58fd7dbd2b05daf240a97c3d5cb4f950e7827bb4 (patch)
tree6ecf9c0215d07d68a0b0e786712f675f59518dcb
parent7528e948a5f526b642ca036be0f793aa9d92884e (diff)
downloadaur-58fd7dbd2b05daf240a97c3d5cb4f950e7827bb4.tar.gz
Updated to build against nginx-mainline-mod-src
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
2 files changed, 15 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2121216d9547..a32655c43c23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
pkgbase = nginx-mainline-mod-memc
pkgdesc = Extended version of the standard memcached module for mainline nginx
pkgver = 0.19
- pkgrel = 24
+ pkgrel = 25
url = https://github.com/openresty/memc-nginx-module
arch = i686
arch = x86_64
license = BSD
+ makedepends = nginx-mainline-src
depends = nginx-mainline
- source = https://nginx.org/download/nginx-1.19.3.tar.gz
- source = https://nginx.org/download/nginx-1.19.3.tar.gz.asc
source = https://github.com/openresty/memc-nginx-module/archive/v0.19/memc-0.19.tar.gz
- validpgpkeys = B0F4253373F8F6F510D42178520A9993A1C052F8
- sha256sums = 91e5b74fa17879d2463294e93ad8f6ffc066696ae32ad0478ffe15ba0e9e8df0
- sha256sums = SKIP
sha256sums = 8c2bdbe875e4f5225d0778bfb09a2668f9281d7de6218c7b462a7ba2cee06fe8
pkgname = nginx-mainline-mod-memc
diff --git a/PKGBUILD b/PKGBUILD
index 4509be979281..dbde40590b69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,38 +2,35 @@
pkgname=nginx-mainline-mod-memc
pkgver=0.19
-pkgrel=24
+pkgrel=25
_modname="${pkgname#nginx-mainline-mod-}"
-_nginxver=1.19.3
pkgdesc='Extended version of the standard memcached module for mainline nginx'
arch=('i686' 'x86_64')
depends=('nginx-mainline')
+makedepends=('nginx-mainline-src')
url="https://github.com/openresty/memc-nginx-module"
license=('BSD')
-source=(
- https://nginx.org/download/nginx-$_nginxver.tar.gz{,.asc}
- https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz
-)
+source=(https://github.com/openresty/$_modname-nginx-module/archive/v$pkgver/$_modname-$pkgver.tar.gz)
+sha256sums=('8c2bdbe875e4f5225d0778bfb09a2668f9281d7de6218c7b462a7ba2cee06fe8')
-validpgpkeys=(
- 'B0F4253373F8F6F510D42178520A9993A1C052F8' # Maxim Dounin <mdounin@mdounin.ru>
-)
-
-sha256sums=('91e5b74fa17879d2463294e93ad8f6ffc066696ae32ad0478ffe15ba0e9e8df0'
- 'SKIP'
- '8c2bdbe875e4f5225d0778bfb09a2668f9281d7de6218c7b462a7ba2cee06fe8')
+prepare() {
+ mkdir -p build
+ cd build
+ ln -sf /usr/src/nginx/auto
+ ln -sf /usr/src/nginx/src
+}
build() {
- cd "$srcdir"/nginx-$_nginxver
- ./configure --with-compat --add-dynamic-module=../$_modname-nginx-module-$pkgver
+ cd build
+ /usr/src/nginx/configure --with-compat --add-dynamic-module=../$_modname-nginx-module-$pkgver
make modules
}
package() {
- cd "$srcdir"/nginx-$_nginxver/objs
+ cd build/objs
for mod in *.so; do
install -Dm755 $mod "$pkgdir"/usr/lib/nginx/modules/$mod
done