summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-01-20 07:12:19 +0000
committerGeorge Rawlinson2022-01-20 07:12:19 +0000
commit591da70e4d261bef9e8f9c73e74cd16c09f371ef (patch)
tree4498d178d30737b31209a23ae8b2b70170690a3a
parent21d8f5335c397f6590e5460690af5eb6b76deaeb (diff)
downloadaur-591da70e4d261bef9e8f9c73e74cd16c09f371ef.tar.gz
upgpkg: kcgi 0.13.0-1
* New upstream release. * Switch source to git commit from tarball. * Remove license file, as it is included with source. * Enable seccomp. * Add missing makedepends: git, libseccomp, libmd.
-rw-r--r--.SRCINFO14
-rw-r--r--LICENSE13
-rw-r--r--PKGBUILD48
3 files changed, 40 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e12536efeaae..9fe8a6f47d41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = kcgi
pkgdesc = Minimal CGI and FastCGI library
- pkgver = 0.12.2
+ pkgver = 0.13.0
pkgrel = 1
url = http://kristaps.bsd.lv/kcgi/
arch = i686
arch = x86_64
- license = custom
+ license = custom:ISC
+ makedepends = git
makedepends = bmake
+ makedepends = libseccomp
+ makedepends = libmd
depends = glibc
- source = https://kristaps.bsd.lv/kcgi/snapshots/kcgi-0.12.2.tgz
- source = LICENSE
- sha512sums = f28dd2134936036c44bbd3fc094e512c52019e0dc39f085a396924331c0e7f0bb940cee8afae43147674065b7d5a1d057c56cfdb0040131b72da53dff2289d31
- sha512sums = b040c157fe8b95a41a0375d2cd3cc4e6406a988ed5f337b0c6dd15f1ea08344196018a5c2353c2acfbde7858ca5e0f2bf00d1cc4890661effadf39e239a95520
+ source = git+https://github.com/kristapsdz/kcgi.git#commit=2601ac1ef77345902f4c86f08924cfc678227e86
+ b2sums = SKIP
pkgname = kcgi
-
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 1c75a83662f0..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,13 +0,0 @@
-Copyright (c) 2012--2016, Kristaps Dzonsons <kristaps@bsd.lv>
-
-Permission to use, copy, modify, and/or distribute this software for any purpose
-with or without fee is hereby granted, provided that the above copyright notice
-and this permission notice appear in all copies.
-
-THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH
-REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND
-FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT,
-INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
-OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
-TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF
-THIS SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 9f5f1868a32c..993b85efe7cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,62 @@
-# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+# Contributor: Adrian Perez de Castro <aperez@igalia.com>
# Contributor: Wilhelm Schuster <wilhelm [aT] wilhelm [.] re>
pkgname=kcgi
-pkgver=0.12.2
+pkgver=0.13.0
pkgrel=1
pkgdesc="Minimal CGI and FastCGI library"
arch=('i686' 'x86_64')
url="http://kristaps.bsd.lv/kcgi/"
-license=('custom')
+license=('custom:ISC')
depends=('glibc')
-makedepends=('bmake')
-source=("https://kristaps.bsd.lv/kcgi/snapshots/$pkgname-$pkgver.tgz"
- "LICENSE")
-sha512sums=('f28dd2134936036c44bbd3fc094e512c52019e0dc39f085a396924331c0e7f0bb940cee8afae43147674065b7d5a1d057c56cfdb0040131b72da53dff2289d31'
- 'b040c157fe8b95a41a0375d2cd3cc4e6406a988ed5f337b0c6dd15f1ea08344196018a5c2353c2acfbde7858ca5e0f2bf00d1cc4890661effadf39e239a95520')
+makedepends=('git' 'bmake' 'libseccomp' 'libmd')
+_commit='2601ac1ef77345902f4c86f08924cfc678227e86'
+source=("git+https://github.com/kristapsdz/kcgi.git#commit=$_commit")
+b2sums=('SKIP')
-build() {
- cd $pkgname-$pkgver
+pkgver() {
+ cd kcgi
+
+ git describe --tags | sed -e 's/VERSION_//' -e 's/_/./g'
+}
- ./configure PREFIX=/usr MANDIR=/usr/share/man SBINDIR=/usr/bin LDFLAGS="${LDFLAGS}"
+prepare() {
+ cd kcgi
+
+ ./configure \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ SBINDIR=/usr/bin \
+ LDFLAGS="$LDFLAGS"
# This is a bit hackish, but it manages to add the linker flags for kfcgi.
# The "configure" script picks LDFLAGS from the environment, but then it
# does not use the variable in the target ¯\_(ツ)_/¯
echo 'LDADD_LIB_SOCKET += $(LDFLAGS)' >> Makefile.configure
+ # enable seccomp filter
+ sed -i 's/#CPPFLAGS/CPPFLAGS/' Makefile
+}
+
+build() {
+ cd kcgi
+
bmake
}
check() {
- cd $pkgname-$pkgver
+ cd kcgi
bmake regress
}
package() {
- cd $pkgname-$pkgver
+ cd kcgi
bmake DESTDIR="$pkgdir" install
- strip -x --strip-unneeded "${pkgdir}/usr/bin/kfcgi"
- install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ strip -x --strip-unneeded "$pkgdir/usr/bin/kfcgi"
+
+ install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE.md
}