summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Henrie2022-12-23 00:40:22 -0700
committerAlex Henrie2022-12-23 00:40:22 -0700
commit595bd320bb1a9bc9aba08e7759a153d603faa755 (patch)
tree433988e06930b85b17abd81a75478e754f7347f6
parent43bc5a80991e8f57099b48785914083b550ec7d4 (diff)
downloadaur-595bd320bb1a9bc9aba08e7759a153d603faa755.tar.gz
Don't strip the included libraries
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc70f3b34dab..4276726ae2db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = esp-idf
pkgdesc = Espressif IoT Development Framework. Official development framework for ESP32.
pkgver = 5.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/espressif/esp-idf
install = esp-idf.install
arch = i686
@@ -23,6 +23,7 @@ pkgbase = esp-idf
depends = python-pyserial
depends = python-virtualenv
noextract = esp-idf-v5.0.zip
+ options = !strip
source = https://github.com/espressif/esp-idf/releases/download/v5.0/esp-idf-v5.0.zip
sha512sums = 0fa438ca9afbc02a65259ae21e4957950eb3a373174bbc288b2f316b57a9384ac668ce487ae31373ff27dda85b8300e4c63ef927afce7a35380f8d2e793a4ea0
diff --git a/PKGBUILD b/PKGBUILD
index 444122872713..f8b56d4ed161 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Alex Henrie <alexhenrie24@gmail.com>
pkgname=esp-idf
pkgver=5.0
-pkgrel=2
+pkgrel=3
pkgdesc="Espressif IoT Development Framework. Official development framework for ESP32."
arch=('i686' 'x86_64' 'aarch' 'aarch64' 'armv7h')
url="https://github.com/espressif/esp-idf"
license=('APACHE')
depends=('cmake' 'git' 'libusb' 'python' 'python-click' 'python-cryptography' 'python-future' 'python-pyelftools' 'python-pyparsing' 'python-pyserial' 'python-virtualenv')
makedepends=('unzip')
+options=('!strip')
install='esp-idf.install'
source=(https://github.com/espressif/${pkgname}/releases/download/v${pkgver}/${pkgname}-v${pkgver}.zip)
noextract=(${pkgname}-v${pkgver}.zip)