summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTechcable2022-12-10 19:47:40 -0700
committerTechcable2022-12-10 19:47:40 -0700
commit597076a606b4c3b643941737292a7a6f8b5409e5 (patch)
tree63409276681ac53acbcc0d40f4ac5147806cc5b4
parentb3a52dbb0c779ded5e0e1060b3510f8666f21ef4 (diff)
downloadaur-597076a606b4c3b643941737292a7a6f8b5409e5.tar.gz
Add hello.zig to sources array
Thanks to @dithpri for suggesting this changes. Update version to 0.11.0_dev.681+f02073434
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc5197ee8a88..ade9c250bb60 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = zig-dev-bin
pkgdesc = A general-purpose programming language and toolchain for maintaining robust, optimal, and reusable software
- pkgver = 0.10.0_dev.3880+e2bb92b2e
- pkgrel = 2
+ pkgver = 0.11.0_dev.681+f02073434
+ pkgrel = 1
epoch = 1
url = https://ziglang.org/
arch = x86_64
@@ -12,5 +12,7 @@ pkgbase = zig-dev-bin
provides = zig
conflicts = zig
options = !strip
+ source = hello.zig
+ sha256sums = SKIP
pkgname = zig-dev-bin
diff --git a/PKGBUILD b/PKGBUILD
index d0e38650e77d..509395c378af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@ pkgname=zig-dev-bin
# "newer" greater than the new version scheme
epoch=1
# NOTE: Hyphen -> underscore
-pkgver=0.10.0_dev.3880+e2bb92b2e
-pkgrel=2
+pkgver=0.11.0_dev.681+f02073434
+pkgrel=1
pkgdesc="A general-purpose programming language and toolchain for maintaining robust, optimal, and reusable software"
arch=('x86_64' 'aarch64')
url="https://ziglang.org/"
@@ -20,12 +20,18 @@ options=('!strip')
provides=('zig')
conflicts=('zig')
# NOTE: We don't include the "real" source until build()
-source=()
+#
+# The exception is our test file `hello.zig`
+source=(
+ "hello.zig"
+)
# GPG verification is not currently possible because Zig binaries aren't signed
# Hardcoded sha256 not possible because this is a an auto-updating (nightly) package
#
# Zig Issue for signed binaries: https://github.com/ziglang/zig/issues/4945
-sha256sums=()
+sha256sums=(
+ "SKIP"
+)
# Prints a warning message to stderr
warning() {
@@ -78,7 +84,7 @@ RELATIVE_LANGREF_FILE="docs/langref.html";
# All of these must be present for
RELATIVE_STDLIB_DOC_FILES=("docs/std/index.html" "docs/std/main.js" "docs/std/data.js");
check() {
- hello_file="$(realpath ../hello.zig)"
+ hello_file="${srcdir}/hello.zig"
# Zig caches (both local and global) can use up a lot of space.
# For these hello world examples (in a frequently updated package), this is very wasteful.
#