summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-04-13 05:53:32 +0200
committersL1pKn072020-04-13 05:53:32 +0200
commit5985330fdb6659781c137ef93588d711ca91cc73 (patch)
treea78ee6a06c3b6ac98a960fef373e373fb715c30b
downloadaur-5985330fdb6659781c137ef93588d711ca91cc73.tar.gz
Initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD68
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d480e9f8504a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = foosynth-plugin-neo_minideen-git
+ pkgdesc = Plugin for Vapoursynth: neo_minideen (Dual interface for Vapoursynth/Avisynth) (GIT version)
+ pkgver = r7.1.gddcbeaa
+ pkgrel = 1
+ url = https://forum.doom9.org/showthread.php?t=176554
+ arch = x86_64
+ license = ISC
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = clang
+ makedepends = avisynthplus
+ makedepends = vapoursynth
+ depends = gcc-libs
+ source = neo_minideen::git+https://github.com/HomeOfAviSynthPlusEvolution/minideen.git
+ sha256sums = SKIP
+
+pkgname = avisynth-plugin-neo_minideen-git
+ pkgdesc = Plugin for Avisynth: neo_minideen (GIT version)
+ depends = avisynthplus
+ provides = avisynth-plugin-neo_minideen
+ conflicts = avisynth-plugin-neo_minideen
+
+pkgname = vapoursynth-plugin-neo_minideen-git
+ pkgdesc = Plugin for Vapoursynth: neo_minideen (GIT version)
+ depends = vapoursynth
+ provides = vapoursynth-plugin-neo_minideen
+ conflicts = vapoursynth-plugin-neo_minideen
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..300a542d8569
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!esee.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3241a1649778
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=neo_minideen
+pkgbase="foosynth-plugin-${_plug}-git"
+pkgname=("avisynth-plugin-${_plug}-git"
+ "vapoursynth-plugin-${_plug}-git"
+ )
+pkgver=r7.1.gddcbeaa
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (Dual interface for Vapoursynth/Avisynth) (GIT version)"
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=176554'
+license=('ISC' 'MIT')
+depends=('gcc-libs')
+makedepends=('git'
+ 'cmake'
+ 'clang'
+ 'avisynthplus'
+ 'vapoursynth'
+ )
+source=("${_plug}::git+https://github.com/HomeOfAviSynthPlusEvolution/minideen.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+
+ mkdir -p build
+
+ sed '1i#include <cpuid.h>' -i src/cpuid.cpp
+}
+
+build() {
+ cd "${_plug}/build"
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
+
+ make
+}
+
+package_avisynth-plugin-neo_minideen-git() {
+ pkgdesc="Plugin for Avisynth: ${_plug} (GIT version)"
+ depends=('avisynthplus')
+ provides=("avisynth-plugin-${_plug}")
+ conflicts=("avisynth-plugin-${_plug}")
+
+ install -Dm644 "${_plug}/build/libneo-minideen.so" "${pkgdir}/usr/lib/avisynth/libneo-minideen.so"
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/avisynth/plugins/${_plug}/README.md"
+
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_vapoursynth-plugin-neo_minideen-git() {
+ pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+ depends=('vapoursynth')
+ provides=("vapoursynth-plugin-${_plug}")
+ conflicts=("vapoursynth-plugin-${_plug}")
+
+ install -Dm644 "${_plug}/build/libneo-minideen.so" "${pkgdir}/usr/lib/vapoursynth/libneo-minideen.so"
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}