summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commit598d8010f2b944da5ae8d01ef3e7755bee08bf4a (patch)
treeed51aa44e78fddb46288804ac0059627f43c0328
downloadaur-598d8010f2b944da5ae8d01ef3e7755bee08bf4a.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
-rw-r--r--.SRCINFO34
-rw-r--r--10-makefile-fix.patch20
-rw-r--r--20-build_without_data_archive.patch32
-rw-r--r--40-archlinux_package.patch28
-rw-r--r--PKGBUILD48
-rw-r--r--milena.install14
6 files changed, 176 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ecb51943e6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = milena
+ pkgdesc = Milena is a Polish speech synthesizer for Linux
+ pkgver = 0.2.87
+ pkgrel = 1
+ url = http://milena.polip.com/
+ install = milena.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = milena-data
+ depends = mbrola-voices-pl1
+ depends = enca
+ depends = antiword
+ depends = odt2txt
+ depends = poppler
+ depends = libao
+ depends = sox
+ optdepends = milena-basewords: for milena_book
+ optdepends = lame: for milena_book
+ optdepends = vorbis-tools: for milena_book
+ optdepends = faac: for milena_book
+ optdepends = amrwb: for milena_nokia
+ optdepends = ImageMagick: for milena_nokia
+ source = http://tts.polip.com/files/milena-dist-0.2.87.tar.gz
+ source = 10-makefile-fix.patch
+ source = 20-build_without_data_archive.patch
+ source = 40-archlinux_package.patch
+ sha512sums = 91e53b4f1c49fa2e1f70b9bcea48991b8d21c702006f521ce225c0f5c81a43557a2b26ad17ec830322ebab74534cf57f1fe94631d21e926bd8310c90a82a08de
+ sha512sums = 8166da0000e3e8f7c2503f04049ed1c527d67cf1715474a84dfcafce8d727b104d38d19aa76f7ce467a0645823edd36c7e482e58bd309059a5543d3b5c30c1f1
+ sha512sums = 9b38b09353e1bee86af9956c983d9a43f5827dac74ca1f91c74ae8587e93a2b2fae7800de100d8f27b7b36a21f7148ad07291ae5995fdeffc768a1a2802ccb32
+ sha512sums = 43cd6e0760f63319336df8c5915509324672d30a2ca70d2d9653dc60871839892dcca087d2b641474330a114a0c9773ab9304832c86ca5027499a777c8613eeb
+
+pkgname = milena
+
diff --git a/10-makefile-fix.patch b/10-makefile-fix.patch
new file mode 100644
index 000000000000..3d3bc6f2656d
--- /dev/null
+++ b/10-makefile-fix.patch
@@ -0,0 +1,20 @@
+--- orig/Makefile 2013-04-20 05:31:14.000000000 +0000
++++ patch/Makefile 2013-04-20 13:46:26.000000000 +0000
+@@ -1,5 +1,4 @@
+-
+-export prefix=/usr/local
++export prefix ?= /usr/local
+ export milena_dir=$(prefix)/share/milena
+ export doc_dir=$(prefix)/share/doc/milena
+ export speechd_dir=$(shell ./find_speechd)
+@@ -31,8 +30,8 @@
+ install:
+ make -C src install
+ ldconfig
+- mkdir -p $(doc_dir)
+- install -m 644 README* $(doc_dir)
++ mkdir -p $(DESTDIR)$(doc_dir)
++ install -m 644 README* $(DESTDIR)$(doc_dir)
+ make -C data install
+ make -C utils install
+
diff --git a/20-build_without_data_archive.patch b/20-build_without_data_archive.patch
new file mode 100644
index 000000000000..a2f193509c9f
--- /dev/null
+++ b/20-build_without_data_archive.patch
@@ -0,0 +1,32 @@
+--- orig/Makefile 2013-04-20 13:49:21.000000000 +0000
++++ patch/Makefile 2013-04-20 13:48:51.000000000 +0000
+@@ -10,7 +10,6 @@
+
+ all: config.dat
+ make -C src all
+- make -C data all
+ make -C utils all
+
+ milena.exe: config.dat
+@@ -24,7 +23,6 @@
+ clean:
+ rm -f config.dat
+ make -C src clean
+- make -C data clean
+ make -C utils clean
+
+ install:
+@@ -32,7 +30,6 @@
+ ldconfig
+ mkdir -p $(DESTDIR)$(doc_dir)
+ install -m 644 README* $(DESTDIR)$(doc_dir)
+- make -C data install
+ make -C utils install
+
+ uninstall:
+@@ -40,5 +37,4 @@
+ if [ -d $(doc_dir) ] ; then rmdir --ignore-fail-on-non-empty $(doc_dir);fi
+ make -C src uninstall
+ ldconfig
+- make -C data uninstall
+ make -C utils uninstall
diff --git a/40-archlinux_package.patch b/40-archlinux_package.patch
new file mode 100644
index 000000000000..e571630d2abf
--- /dev/null
+++ b/40-archlinux_package.patch
@@ -0,0 +1,28 @@
+diff -Naur orig/Makefile patch/Makefile
+--- orig/Makefile 2013-04-20 13:49:52.000000000 +0000
++++ patch/Makefile 2013-04-20 13:51:06.000000000 +0000
+@@ -27,7 +27,6 @@
+
+ install:
+ make -C src install
+- ldconfig
+ mkdir -p $(DESTDIR)$(doc_dir)
+ install -m 644 README* $(DESTDIR)$(doc_dir)
+ make -C utils install
+diff -Naur orig/src/Makefile patch/src/Makefile
+--- orig/src/Makefile 2013-04-20 05:31:14.000000000 +0000
++++ patch/src/Makefile 2013-04-20 13:53:36.000000000 +0000
+@@ -70,10 +70,12 @@
+ rm -f *~ *.o *.so *.exe milena milena.h milena.pc milena_cyrillic.h
+
+ install: milena
++ install -dm 0755 $(DESTDIR)$(prefix)/{bin,include}
++ install -dm 0755 $(DESTDIR)$(LIBDIR)/pkgconfig
+ install -m 0755 milena $(DESTDIR)$(prefix)/bin
+ install -m 0755 libmilena.so libmilena_mbrola.so $(DESTDIR)$(LIBDIR)
+ install -m 0644 milena.h milena_mbrola.h $(DESTDIR)$(prefix)/include/
+- if [ -d $(LIBDIR)/pkgconfig ] ; then install -m 0644 milena.pc $(DESTDIR)$(LIBDIR)/pkgconfig; fi
++ if [ -d $(LIBDIR)/pkgconfig ] ; then install -m 0644 milena.pc $(DESTDIR)$(LIBDIR)/pkgconfig/milena.pc; fi
+
+ uninstall:
+ rm -f $(DESTDIR)$(prefix)/bin/milena
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b38f14886c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: 3ED <krzysztof1987 _at_ gmail _dot_ com>
+
+pkgname=milena
+pkgver=0.2.87
+pkgrel=1
+pkgdesc="Milena is a Polish speech synthesizer for Linux"
+arch=('i686' 'x86_64')
+url="http://milena.polip.com/"
+license=('GPL')
+depends=('milena-data' 'mbrola-voices-pl1' 'enca' 'antiword' 'odt2txt' 'poppler' 'libao' 'sox')
+install=milena.install
+optdepends=('milena-basewords: for milena_book'
+ 'lame: for milena_book'
+ 'vorbis-tools: for milena_book'
+ 'faac: for milena_book'
+ 'amrwb: for milena_nokia'
+ 'ImageMagick: for milena_nokia')
+source=(http://tts.polip.com/files/$pkgname-dist-$pkgver.tar.gz
+ 10-makefile-fix.patch
+ 20-build_without_data_archive.patch
+ 40-archlinux_package.patch)
+sha512sums=('91e53b4f1c49fa2e1f70b9bcea48991b8d21c702006f521ce225c0f5c81a43557a2b26ad17ec830322ebab74534cf57f1fe94631d21e926bd8310c90a82a08de'
+ '8166da0000e3e8f7c2503f04049ed1c527d67cf1715474a84dfcafce8d727b104d38d19aa76f7ce467a0645823edd36c7e482e58bd309059a5543d3b5c30c1f1'
+ '9b38b09353e1bee86af9956c983d9a43f5827dac74ca1f91c74ae8587e93a2b2fae7800de100d8f27b7b36a21f7148ad07291ae5995fdeffc768a1a2802ccb32'
+ '43cd6e0760f63319336df8c5915509324672d30a2ca70d2d9653dc60871839892dcca087d2b641474330a114a0c9773ab9304832c86ca5027499a777c8613eeb')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ for (( i=0; i < ${#source[@]}; i++ )); do
+ if [ "${source[i]##*.}" = "patch" ]; then
+ msg2 "Applying patch: ${source[i]##*/}"
+ patch -Np1 -i "${srcdir}/${source[i]##*/}"
+ fi
+ done
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make prefix="/usr"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" prefix="/usr" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/milena.install b/milena.install
new file mode 100644
index 000000000000..c980ddfab7ea
--- /dev/null
+++ b/milena.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo "Updating Shared Library Links"
+ /sbin/ldconfig
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: