summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkleintux2023-10-02 16:06:26 +0200
committerkleintux2023-10-02 16:06:26 +0200
commit59aa247cbcb3ae4fa5e079bb985dbf93098e7d95 (patch)
tree14673c172389bbab45170cdb700490d24ac61774
parent95661cbe1d5f059cece3b098e9894618bcd43eb5 (diff)
downloadaur-59aa247cbcb3ae4fa5e079bb985dbf93098e7d95.tar.gz
added git as makedependency
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c81d521fbb76..b1907f982c26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = glmviz-git
pkgdesc = High framerate, dB correct OpenGL music visualizer with FiFo buffers and PulseAudio input support
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hannesha/GLMViz
- arch = x86_64
+ arch = any
license = GPL3
+ makedepends = git
depends = glm
depends = fftw
depends = glfw-x11
@@ -14,4 +15,3 @@ pkgbase = glmviz-git
md5sums = SKIP
pkgname = glmviz-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d511874930ee..1d7d3556275e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
-# Maintainer: Pablo Moyano (p4block)
+# Contributor: <reg-archlinux AT klein DOT tuxli DOT ch>
+# Contributor: Pablo Moyano (p4block)
+
pkgname=glmviz-git
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc='High framerate, dB correct OpenGL music visualizer with FiFo buffers and PulseAudio input support'
-arch=('x86_64')
+arch=('any')
url='https://github.com/hannesha/GLMViz'
license=('GPL3')
-depends=(glm fftw glfw-x11 libconfig)
+depends=('glm' 'fftw' 'glfw-x11' 'libconfig')
+makedepends=('git')
optdepends=(pulseaudio)
source=("git+https://github.com/hannesha/GLMViz.git")
md5sums=('SKIP')
build() {
-
cd "${srcdir}/GLMViz"
mkdir -p build
cd build
cmake ..
-
}
package() {
cd "${srcdir}/GLMViz/build"
make DESTDIR=${pkgdir} install
-
}