summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2021-01-21 20:36:54 +0900
committerQue Quotion2021-01-21 20:36:54 +0900
commit59b42169019b308440838be65bf147820c67baf2 (patch)
tree223f00d1a79ccd67e100599ec4cfc30c19a5f515
parent7ad27cb6d7ddb783bce2e9ba98842d4ffe202340 (diff)
downloadaur-59b42169019b308440838be65bf147820c67baf2.tar.gz
Repackage: use latest stable release and elementary's patches
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD34
-rw-r--r--contracts.patch41
3 files changed, 67 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11145c0a47f4..7602daec58c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = file-roller-pantheon
- pkgdesc = Archive manipulator for GNOME (with elementary OS patches)
- pkgver = 3.28.0+1ubuntu1+r4.4ab5e02aa
+ pkgdesc = Archive manipulator for Pantheon
+ pkgver = 3.38.0
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/file-roller/
arch = i686
@@ -24,10 +24,13 @@ pkgbase = file-roller-pantheon
optdepends = unrar: better RAR archive support
optdepends = unace: ACE archive support
optdepends = lrzip: lrzip archive support
- provides = file-roller=3.28.0+1ubuntu1+r4.4ab5e02aa
+ optdepends = squashfs-tools: squashfs image support
+ provides = file-roller=3.38.0
conflicts = file-roller
- source = git+https://github.com/elementary/os-patches.git#branch=file-roller-bionic-patched
+ source = git+https://gitlab.gnome.org/GNOME/file-roller.git#commit=25f9db9770ff5f68aeaffce2e329ef39ae47729d
+ source = contracts.patch
sha256sums = SKIP
+ sha256sums = d559e817b16bee842bf0081fd9832e11439b83c8604a035372893c231cfe15f3
pkgname = file-roller-pantheon
diff --git a/PKGBUILD b/PKGBUILD
index f6496fbb0e0b..051203be7647 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Adria Arrufat <adria DOT arrufat+aur AT protonmail DOT ch>
pkgname=file-roller-pantheon
-pkgver=3.28.0+1ubuntu1+r4.4ab5e02aa
+pkgver=3.38.0
pkgrel=1
-pkgdesc="Archive manipulator for GNOME (with elementary OS patches)"
+pkgdesc="Archive manipulator for Pantheon"
url="https://gitlab.gnome.org/GNOME/file-roller/"
arch=('i686' 'x86_64')
license=('GPL')
@@ -13,27 +13,31 @@ makedepends=(yelp-tools git libnautilus-extension meson appstream-glib)
optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
'unrar: better RAR archive support'
'unace: ACE archive support'
- 'lrzip: lrzip archive support')
+ 'lrzip: lrzip archive support'
+ 'squashfs-tools: squashfs image support')
groups=(pantheon)
provides=(file-roller="${pkgver}")
conflicts=(file-roller)
-source=("git+https://github.com/elementary/os-patches.git#branch=file-roller-bionic-patched")
-sha256sums=('SKIP')
+_commit=25f9db9770ff5f68aeaffce2e329ef39ae47729d # tags/3.38.0^0
+source=("git+https://gitlab.gnome.org/GNOME/file-roller.git#commit=$_commit"
+ "contracts.patch")
+sha256sums=('SKIP'
+ 'd559e817b16bee842bf0081fd9832e11439b83c8604a035372893c231cfe15f3')
-pkgver() {
- cd "os-patches"
-
- printf "3.28.0+1ubuntu1+r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+prepare() {
+ cd "file-roller"
+ patch -Np1 < ../contracts.patch
}
build() {
- cd "os-patches"
- [ -d build ] && rm -rf build
- arch-meson build
- ninja -C build
+ arch-meson file-roller build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
}
package() {
- cd "os-patches"
- DESTDIR="${pkgdir}" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
}
diff --git a/contracts.patch b/contracts.patch
new file mode 100644
index 000000000000..c27fe20281dd
--- /dev/null
+++ b/contracts.patch
@@ -0,0 +1,41 @@
+diff --git a/data/file-roller-compress.contract b/data/file-roller-compress.contract
+new file mode 100644
+index 000000000..8de5396d3
+--- /dev/null
++++ b/data/file-roller-compress.contract
+@@ -0,0 +1,8 @@
++[Contractor Entry]
++Name=Compress
++Icon=add-files-to-archive
++Description=Create a compressed archive with the selected objects
++MimeType=!archive;inode/blockdevice;inode/chardevice;inode/fifo;inode/socket;
++Exec=file-roller --add %U
++Gettext-Domain=file-roller
++
+diff --git a/data/file-roller-extract-here.contract b/data/file-roller-extract-here.contract
+new file mode 100644
+index 000000000..184a6f248
+--- /dev/null
++++ b/data/file-roller-extract-here.contract
+@@ -0,0 +1,7 @@
++[Contractor Entry]
++Name=Extract Here
++Icon=extract-archive
++Description=Extract the contents of the archives in the archive folder and quit the program
++MimeType=application/x-7z-compressed;application/x-7z-compressed-tar;application/x-ace;application/x-alz;application/x-ar;application/x-arj;application/x-bzip;application/x-bzip-compressed-tar;application/x-bzip1;application/x-bzip1-compressed-tar;application/x-cabinet;application/x-cbr;application/x-cbz;application/x-cd-image;application/x-compress;application/x-compressed-tar;application/x-cpio;application/x-deb;application/x-ear;application/x-ms-dos-executable;application/x-gtar;application/x-gzip;application/x-gzpostscript;application/x-java-archive;application/x-lha;application/x-lhz;application/x-lrzip;application/x-lrzip-compressed-tar;application/x-lzip;application/x-lzip-compressed-tar;application/x-lzma;application/x-lzma-compressed-tar;application/x-lzop;application/x-lzop-compressed-tar;application/x-ms-wim;application/x-rar;application/x-rar-compressed;application/x-rpm;application/x-rzip;application/x-tar;application/x-tarz;application/x-stuffit;application/x-war;application/x-xz;application/x-xz-compressed-tar;application/x-zip;application/x-zip-compressed;application/x-zoo;application/zip;
++Exec=file-roller --extract-here %U
++Gettext-Domain=file-roller
+diff --git a/data/meson.build b/data/meson.build
+index e66726ce7..0504bf78a 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -1,5 +1,9 @@
+ po_dir = join_paths(meson.source_root(), 'po')
+
++install_data('file-roller-compress.contract', 'file-roller-extract-here.contract',
++ install_dir : join_paths(datadir, 'contractor')
++)
++
+ install_data('org.gnome.FileRoller.gschema.xml',
+ install_dir : join_paths(datadir, 'glib-2.0', 'schemas')
+ )