summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-17 22:04:09 -0500
committerCarlos Aznarán Laos2023-05-17 22:04:09 -0500
commit59e9cc1b23337e71d60429a5d17495b5e0745261 (patch)
tree6087cf719a26663a816de50611ee12f9f7d56945
parenta190fa0704e1e5b54f4bc2f66be8ff47e74986bd (diff)
downloadaur-59e9cc1b23337e71d60429a5d17495b5e0745261.tar.gz
Bump version to 0.17.1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD54
2 files changed, 27 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2359205104c5..d4f06c8d842f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,18 +5,17 @@ pkgbase = python-vt-py
url = https://github.com/virustotal/vt-py
arch = any
license = Apache
- checkdepends = python-pytest
checkdepends = python-pytest-asyncio
checkdepends = python-pytest-httpserver
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
- makedepends = python-sphinx
makedepends = python-wheel
+ makedepends = python-sphinx
depends = python-aiohttp
provides = python-virustotal
replaces = python-virustotal-api
source = python-vt-py-0.17.1.tar.gz::https://github.com/virustotal/vt-py/archive/0.17.1.tar.gz
- sha256sums = 99cddf626172fa35b9185c2dbb610698461590931bd80c4243b679f8052ce4f4
+ sha512sums = 89c8caa12fee7e547d3a3c069efecd85ba71272f1e18039508e1a6e72b917663b94fed0415294c4e63d9134a6031c0aaba62be46aa7184bc668245f091579871
pkgname = python-vt-py
diff --git a/PKGBUILD b/PKGBUILD
index edcfb0b536c5..f93e57372443 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,40 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
-
-pkgname=python-vt-py
-_pkg="${pkgname#python-}"
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
+_base=vt-py
+pkgname=python-${_base}
pkgver=0.17.1
pkgrel=1
pkgdesc="Official Python client library for VirusTotal's REST API"
-arch=('any')
-url="https://github.com/virustotal/vt-py"
-license=('Apache')
-depends=('python-aiohttp')
-makedepends=(
- 'python-build'
- 'python-installer'
- 'python-setuptools'
- 'python-sphinx'
- 'python-wheel')
-checkdepends=('python-pytest' 'python-pytest-asyncio' 'python-pytest-httpserver')
-provides=('python-virustotal')
-replaces=('python-virustotal-api')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('99cddf626172fa35b9185c2dbb610698461590931bd80c4243b679f8052ce4f4')
+arch=(any)
+url="https://github.com/virustotal/${_base}"
+license=(Apache)
+depends=(python-aiohttp)
+makedepends=(python-build python-installer python-setuptools python-wheel python-sphinx)
+checkdepends=(python-pytest-asyncio python-pytest-httpserver)
+provides=(python-virustotal)
+replaces=(python-virustotal-api)
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('89c8caa12fee7e547d3a3c069efecd85ba71272f1e18039508e1a6e72b917663b94fed0415294c4e63d9134a6031c0aaba62be46aa7184bc668245f091579871')
prepare() {
- cd "$_pkg-$pkgver"
- sed -i '/setup_requires/d' setup.py
+ sed -i '/setup_requires/d' ${_base}-${pkgver}/setup.py
}
build() {
- cd "$_pkg-$pkgver"
- python -m build --wheel --no-isolation
- PYTHONPATH="$PWD" sphinx-build -b man docs/source _build
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
+ PYTHONPATH="${PWD}" sphinx-build -b man docs/source _build
}
check() {
- cd "$_pkg-$pkgver"
- pytest -x --disable-warnings
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest
}
package() {
- cd "$_pkg-$pkgver"
- PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 "_build/$_pkg.1" -t "$pkgdir/usr/share/man/man1/"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm644 "_build/${_base}.1" -t "$pkgdir/usr/share/man/man1/"
}