summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroger2015-06-30 10:40:39 -0300
committerroger2015-06-30 10:40:39 -0300
commit59ecb492c2602d95cc3e0ec1701fa4e0b49a170e (patch)
tree5388b39b43f484d3ad5d7bdec44c830788f22089
downloadaur-59ecb492c2602d95cc3e0ec1701fa4e0b49a170e.tar.gz
initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD41
-rw-r--r--qtile-python3-git.install11
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e663e95cdd8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = qtile-python3-git
+ pkgdesc = Python3 full-featured, pure-Python tiling window manager. (git version)
+ pkgver = 1998.9713e17
+ pkgrel = 2
+ url = http://www.qtile.org
+ install = qtile-python3-git.install
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ depends = pango
+ depends = python-xcffib>=0.1.10
+ depends = python-cairocffi
+ optdepends = python-setproctitle: change the process name to qtile
+ provides = qtile
+ conflicts = qtile
+ source = git://github.com/qtile/qtile.git
+ md5sums = SKIP
+
+pkgname = qtile-python3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0574d10ba69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: roger <roger@rogerpc.com.ar>
+
+pkgname=qtile-python3-git
+pkgver=1998.9713e17
+pkgrel=2
+pkgdesc="Python3 full-featured, pure-Python tiling window manager. (git version)"
+arch=('any')
+url="http://www.qtile.org"
+license=('MIT')
+depends=('python' 'pango' 'python-xcffib>=0.1.10' 'python-cairocffi')
+makedepends=('python-setuptools' 'git')
+optdepends=('python-setproctitle: change the process name to qtile')
+provides=('qtile')
+conflicts=('qtile')
+install=${pkgname}.install
+source=('git://github.com/qtile/qtile.git')
+md5sums=('SKIP')
+
+_gitname="qtile"
+
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd $_gitname
+ # license
+ msg "Copying license..."
+ install -D -m 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ msg "Copying default config..."
+ install -D -m 644 $srcdir/$_gitname/libqtile/resources/default_config.py $pkgdir/usr/share/doc/$pkgname/default_config.py
+
+ msg "Copying desktop file..."
+ install -D -m 644 $srcdir/$_gitname/resources/qtile.desktop $pkgdir/usr/share/xsessions/qtile.desktop
+
+ # install
+ msg "Running setup.py"
+ python setup.py install --root=${pkgdir} --prefix=/usr
+}
diff --git a/qtile-python3-git.install b/qtile-python3-git.install
new file mode 100644
index 000000000000..80fcc9179676
--- /dev/null
+++ b/qtile-python3-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo ">>> Qtile Example Config at"
+ echo ">>> /usr/share/doc/qtile-git/default_config.py"
+}
+
+post_upgrade() {
+ echo ">>> Qtile Example Config at"
+ echo ">>> /usr/share/doc/qtile-git/default_config.py"
+}
+
+# vim:set ts=2 sw=2 et: