summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheJackiMonster2020-05-01 16:31:29 +0200
committerTheJackiMonster2020-05-01 16:31:29 +0200
commit5a293e7ea91be6ec1c8d239f53fac746d40c14ab (patch)
treeb92eae90ef0275ab5d962ab681c409f58c47f7db
parent8429987776b0c11374626ef7bd62a0050fb31354 (diff)
downloadaur-5a293e7ea91be6ec1c8d239f53fac746d40c14ab.tar.gz
Updated to latest release 2.0
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD20
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a4b8b3b0ef61..7b7775b06e22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pep-engine-hg
pkgdesc = A Free Software library for automatic key management and encryption of messages.
- pkgver = r4205.f75e9274551f
+ pkgver = 2.0.0
pkgrel = 1
url = https://pep.software
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c291107c373e..7eab0197eec1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=pep-engine
pkgname=$_pkgname-hg
-pkgver=r4205.f75e9274551f
+pkgver=2.0.0
pkgrel=1
pkgdesc="A Free Software library for automatic key management and encryption of messages."
arch=('x86_64' 'i686')
@@ -14,20 +14,26 @@ provides=('pep-engine')
source=("hg+https://pep.foundation/dev/repos/pEpEngine")
md5sums=('SKIP')
+prepare() {
+ cd "$srcdir/pEpEngine"
+
+ hg up $(hg tags | grep Release | sort -r | head -1 | awk '{print $1}')
+
+ echo "PREFIX=$pkgdir/usr" > 'local.conf'
+ echo "PER_MACHINE_DIRECTORY=$pkgdir/usr/share/pEp" >> 'local.conf'
+ echo "YML2_PATH=/usr/bin" >> 'local.conf'
+}
+
pkgver() {
cd "$srcdir/pEpEngine"
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+ hg tags | grep Release | sort -r | head -1 | awk '{print $1}' | cut -c9-
}
build() {
cd "$srcdir/pEpEngine"
- echo "PREFIX=$pkgdir/usr" > 'local.conf'
- echo "PER_MACHINE_DIRECTORY=$pkgdir/usr/share/pEp" >> 'local.conf'
- echo "YML2_PATH=/usr/bin" >> 'local.conf'
-
- make all
+ make
make db
}