summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2015-11-16 17:55:55 +0100
committerMarco Pompili2015-11-16 17:55:55 +0100
commit5a35df67b35a34d6bd5e42fe57f69c52e0be4e24 (patch)
tree4fb88553a76619c27a70de022c71549521408550
downloadaur-5a35df67b35a34d6bd5e42fe57f69c52e0be4e24.tar.gz
Initial Commit, v1.9.124
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1aa012961bc8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = stlsoft
+ pkgdesc = C++ library providing operating system facades and STL extensions.
+ pkgver = 1.9.124
+ pkgrel = 1
+ url = http://www.stlsoft.org/
+ arch = any
+ license = BSD
+ source = https://github.com/synesissoftware/STLSoft-1.9/archive/STLSoft-1.9.124.tar.gz
+ md5sums = 7e64507190925a348ac2eae8d0fe274a
+
+pkgname = stlsoft
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..440c96178230
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+STLSoft-*
+stlsoft-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ec88ae89a79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Marco Pompili <marcs.pompili@gmail.com>
+# Contributor: Marco Pompili <marcs.pompili@gmail.com>
+
+pkgname=stlsoft
+pkgver=1.9.124
+pkgrel=1
+pkgdesc="C++ library providing operating system facades and STL extensions."
+arch=('any')
+url="http://www.stlsoft.org/"
+license=('BSD')
+source=("https://github.com/synesissoftware/STLSoft-1.9/archive/STLSoft-${pkgver}.tar.gz")
+md5sums=('7e64507190925a348ac2eae8d0fe274a')
+
+package() {
+ mkdir -p ${pkgdir}/usr/
+
+ cp -R ${srcdir}/STLSoft-1.9-STLSoft-${pkgver}/include ${pkgdir}/usr/
+}