summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Branham2018-05-31 16:01:09 -0500
committerAlex Branham2018-05-31 16:01:09 -0500
commit5a3690fcdc403be65cca5ff3bb861cafd3d22019 (patch)
tree79e2832fe893301f2753edd44e183ece747cb0bc
parent489c7bcb9063f8803235ad8b1de7d98c7361f410 (diff)
downloadaur-5a3690fcdc403be65cca5ff3bb861cafd3d22019.tar.gz
Package rename
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 31 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e3688490c1a..9570a5a3eb55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
-pkgbase = r-cran-bitops
- pkgdesc = R functions for bitwise operations
- pkgver = 1.0_6
- pkgrel = 2
- url = http://cran.r-project.org/web/packages/bitops/index.html
+pkgbase = r-bitops
+ pkgdesc = Bitwise Operations
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://cran.r-project.org/package=bitops
arch = x86_64
- arch = i686
- license = GPL3
+ license = GPL
depends = r
- source = http://cran.r-project.org/src/contrib/bitops_1.0-6.tar.gz
+ replaces = r-cran-bitops
+ source = https://cran.r-project.org/src/contrib/bitops_1.0-6.tar.gz
md5sums = fba16485a51b1ccd354abde5816b6bdd
-pkgname = r-cran-bitops
+pkgname = r-bitops
diff --git a/PKGBUILD b/PKGBUILD
index 1fb0a677729b..e2071868cdea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,27 @@
-#Maintainer: Orphan
-#generated by: fordprefect <fordprefect@dukun.de>
+# Maintainer: Alex Branham <branham@utexas.edu>
_cranname=bitops
_cranver=1.0-6
-pkgname=r-cran-$_cranname
-pkgver=1.0_6
-pkgrel=2
-pkgdesc="R functions for bitwise operations"
-url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
-arch=('x86_64' 'i686')
-license=('GPL3')
-depends=('r')
-source=("http://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+_pkgtar=${_cranname}_${_cranver}.tar.gz
+pkgname=r-bitops
+pkgver=${_cranver//[:-]/.}
+pkgrel=1
+pkgdesc="Bitwise Operations"
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_cranname}"
+license=('GPL')
+depends=('r' )
+
+
+
+source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
md5sums=('fba16485a51b1ccd354abde5816b6bdd')
-
+replaces=('r-cran-bitops')
+
+build(){
+ R CMD INSTALL ${_pkgtar} -l $srcdir
+}
package() {
- mkdir -p ${pkgdir}/usr/lib/R/library
- cd ${srcdir}
- R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
}
+