summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2020-08-24 20:03:51 +0200
committerSimon Legner2020-08-24 20:03:51 +0200
commit5a3793a241a6b4ddd410cc9ad56a82a9d7889ce1 (patch)
treedf74c2ae9399a17e1d6b7f12e60a447f973f4187
parent7d22e41944fe4ff08de81f1a98f16b4a0ac1e110 (diff)
downloadaur-5a3793a241a6b4ddd410cc9ad56a82a9d7889ce1.tar.gz
upgpkg: luacheck 0.24.0-1
upstream release New GitHub repository: https://github.com/luarocks/luacheck
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7d221e0d234..dc715d62986d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = luacheck
pkgdesc = A tool for linting and static analysis of Lua code.
- pkgver = 0.23.0
- pkgrel = 3
- url = https://github.com/mpeterv/luacheck
+ pkgver = 0.24.0
+ pkgrel = 1
+ url = https://github.com/luarocks/luacheck
arch = any
license = MIT
depends = lua
depends = lua-filesystem
depends = lua-argparse
optdepends = lua-lanes: for parallel checking
- source = https://github.com/mpeterv/luacheck/archive/0.23.0.tar.gz
- sha256sums = b4edf3a7702519502696d4ac7372ed1bd6a82ded63bf81f2b1d7e9b37711be2b
+ source = luacheck-0.24.0.tar.gz::https://github.com/luarocks/luacheck/archive/0.24.0.tar.gz
+ sha256sums = 845ca600d6c48cdb898d46da7844a2b5e102999d0d600e7621feae490b064749
pkgname = luacheck
diff --git a/PKGBUILD b/PKGBUILD
index 5e4f431c8937..c6e38466a533 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,23 @@
# Contributor: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
pkgname=luacheck
-pkgver=0.23.0
-pkgrel=3
+pkgver=0.24.0
+pkgrel=1
pkgdesc="A tool for linting and static analysis of Lua code."
arch=('any')
-url="https://github.com/mpeterv/luacheck"
+url="https://github.com/luarocks/luacheck"
license=('MIT')
depends=('lua' 'lua-filesystem' 'lua-argparse')
optdepends=('lua-lanes: for parallel checking')
-source=("https://github.com/mpeterv/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('b4edf3a7702519502696d4ac7372ed1bd6a82ded63bf81f2b1d7e9b37711be2b')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/luarocks/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('845ca600d6c48cdb898d46da7844a2b5e102999d0d600e7621feae490b064749')
package() {
cd "$pkgname-$pkgver"
- mkdir -p "$pkgdir/usr/share/lua/5.3/luacheck/stages"
- find src/luacheck -maxdepth 1 -type f -exec install -Dm644 {} "$pkgdir/usr/share/lua/5.3/luacheck" \;
- find src/luacheck/stages -maxdepth 1 -type f -exec install -Dm644 {} "$pkgdir/usr/share/lua/5.3/luacheck/stages" \;
+ LUA_VERSION=5.4
+ for subdir in . builtin_standards stages vendor/sha1; do
+ find src/luacheck/$subdir -maxdepth 1 -type f -exec install -Dm644 {} -t "$pkgdir/usr/share/lua/$LUA_VERSION/luacheck/$subdir" \;
+ done
install -Dm755 "bin/luacheck.lua" "$pkgdir/usr/bin/luacheck"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}