summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmmon Smith2016-06-25 02:16:24 -0700
committerAmmon Smith2016-06-25 02:16:24 -0700
commit5a3d6f5e928618e173159d58d171fd651b12246c (patch)
tree67451b7bff221e525d8d2e3dec43d2f3143ac9b3
parent93924b059b830f6f580171cdf49f3b4b778a80f2 (diff)
downloadaur-5a3d6f5e928618e173159d58d171fd651b12246c.tar.gz
Upgrade to v0.7.2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bae55f744d0d..3d57b868fc0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jun 23 08:33:41 UTC 2016
+# Sat Jun 25 09:16:16 UTC 2016
pkgbase = qotd
pkgdesc = A simple RFC 865-compliant QOTD (quote of the day) daemon.
- pkgver = 0.5.0
+ pkgver = 0.7.2
pkgrel = 1
url = https://gitlab.com/ammongit/qotd
install = qotd.install
@@ -15,8 +15,9 @@ pkgbase = qotd
depends = glibc
provides = qotd
conflicts = qotd
+ options = !zipman
backup = etc/qotd.conf
- source = git+https://gitlab.com/ammongit/qotd.git
+ source = https://gitlab.com/ammongit/qotd/repository/archive.tar.gz?ref=v0.7.2
sha256sums = SKIP
pkgname = qotd
diff --git a/PKGBUILD b/PKGBUILD
index 9086f2d1b013..53381107ba66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=qotd
pkgname="$_pkgname"
-pkgver=0.5.0
+pkgver=0.7.2
pkgrel=1
pkgdesc="A simple RFC 865-compliant QOTD (quote of the day) daemon."
arch=('any')
@@ -13,27 +13,24 @@ makedepends=('git' 'gcc' 'ghostscript' 'gzip')
optdepends=()
provides=("$_pkgname")
conflicts=("$_pkgname")
-options=()
+options=('!zipman')
install="$pkgname.install"
-source=("git+https://gitlab.com/ammongit/$_pkgname.git")
+source=("https://gitlab.com/ammongit/qotd/repository/archive.tar.gz?ref=v$pkgver")
sha256sums=('SKIP')
backup=('etc/qotd.conf')
build() {
- cd "$srcdir/$_pkgname"
-
- # Go to the correct commit for this release
- git reset --hard "$(git rev-parse "v$pkgver")"
+ cd "$srcdir/$_pkgname-v$pkgver"*
# Compile sources
make release
}
package() {
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/$_pkgname-v$pkgver"*
+
+ # Install files
make ROOT="$pkgdir" SYSTEMD=1 install
- mkdir -p "$pkgdir/usr/share/man"
- mv "$pkgdir"/usr/share/man{5,8} "$pkgdir/usr/share/man"
install -D -m644 "doc/$_pkgname.pdf" "$pkgdir/usr/share/doc/$_pkgname/$_pkgname.pdf"
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}