summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortheguy1472020-04-21 23:53:24 +0200
committertheguy1472020-04-21 23:53:24 +0200
commit5a404e3d35e4f656b203f80fa8acdc66d8ce8f5d (patch)
tree45d5da6814720619ee8b2532861f60ee71a47fa4
downloadaur-5a404e3d35e4f656b203f80fa8acdc66d8ce8f5d.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD34
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85dd72343cff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = buffalo-git
+ pkgdesc = A Go web development eco-system, designed to make your project easier.
+ pkgver = v0.16.8.r1.g0ffd608c
+ pkgrel = 1
+ url = https://github.com/gobuffalo/buffalo/
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = go>=1.13
+ optdepends = nodejs>=8: frontend
+ optdepends = npm: asset pipeline
+ optdepends = yarn: frontend dependency management
+ optdepends = gcc: for building sqlite3 support
+ optdepends = git: for VCS support
+ conflicts = buffalo-bin
+ source = buffalo-git::git+https://github.com/gobuffalo/buffalo.git
+ md5sums = SKIP
+
+pkgname = buffalo-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c38535d563ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: theguy147 <yakamoz147 (at) protonmail (dot) com>
+pkgname=buffalo-git
+pkgver=v0.16.8.r1.g0ffd608c
+pkgrel=1
+pkgdesc='A Go web development eco-system, designed to make your project easier.'
+arch=('x86_64')
+url="https://github.com/gobuffalo/buffalo/"
+license=('MIT')
+makedepends=('git')
+depends=('go>=1.13')
+optdepends=('nodejs>=8: frontend'
+ 'npm: asset pipeline'
+ 'yarn: frontend dependency management'
+ 'gcc: for building sqlite3 support'
+ 'git: for VCS support')
+conflicts=('buffalo-bin')
+source=("$pkgname::git+https://github.com/gobuffalo/buffalo.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ go build -o dist/buffalo ./buffalo
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "dist/buffalo" "$pkgdir/usr/bin/buffalo"
+ install -Dm644 "LICENSE.txt" "$pkgdir/usr/share/licenses/buffalo/LICENSE"
+}