summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Manganiello2024-01-19 02:13:07 +0100
committerFabio Manganiello2024-01-19 02:13:07 +0100
commit5a55de4ce0674689dddc533b7924867c4f87678b (patch)
tree757bdf19505cd1d66a33feca54b3246919632ab3
parent5f8b5db8311e237a8ea8862656be87b0fca30ec7 (diff)
downloadaur-5a55de4ce0674689dddc533b7924867c4f87678b.tar.gz
Added PYTHONDONTWRITEBYTECODE=1 to prevent the generation of __pycache__ during build
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45529fd71441..49d84a1467d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=platypush
pkgver=0.50.3
-pkgrel=3
+pkgrel=4
pkgdesc="Universal multi-platform command executor and automation manager"
arch=('any')
license=('MIT')
@@ -108,7 +108,7 @@ sha512sums=('700b585367386cdb1043140ffffed576836d2327aec40db983ee46246e319328670
package() {
cd "${srcdir}/${pkgname}"
- python3 setup.py build install --root="${pkgdir}/" --optimize=1
+ PYTHONDONTWRITEBYTECODE=1 python3 setup.py build install --root="${pkgdir}/" --optimize=1
install -m755 -d "${pkgdir}/usr/lib/systemd/user"
install -m644 "${srcdir}/${pkgname}/examples/systemd/platypush.service" "${pkgdir}/usr/lib/systemd/user"