summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-05-13 22:57:03 +0200
committerNarrat2015-05-13 22:57:03 +0200
commit5a7b45202d76fd9afe67adc1750cdccd155250c3 (patch)
tree4e44b3cca853ee3123197955fe9c3eab116f3460
downloadaur-5a7b45202d76fd9afe67adc1750cdccd155250c3.tar.gz
sylpheed: Latest files
History: https://github.com/Narrat/PKGBuilds
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD44
-rw-r--r--sylpheed-lite.install11
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..79105ca385ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = sylpheed-lite
+ pkgdesc = Lightweight in lightweight and user-friendly e-mail client
+ pkgver = 3.4.2
+ pkgrel = 2
+ url = http://sylpheed.sraoss.jp/en/
+ install = sylpheed-lite.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = openssl
+ depends = gpgme
+ depends = desktop-file-utils
+ conflicts = sylpheed
+ options = !libtool
+ source = http://sylpheed.sraoss.jp/sylpheed/v3.4/sylpheed-3.4.2.tar.gz
+ source = http://sylpheed.sraoss.jp/sylpheed/v3.4/sylpheed-3.4.2.tar.gz.asc
+ sha256sums = a4c47b570a5b565d14ff9933cf2e03fcb895034c1f072f9cd2c4a9867a2f2263
+ sha256sums = SKIP
+
+pkgname = sylpheed-lite
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3a3642b6f6ff
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*/src
+*/pkg
+*.gz
+*.xz
+*.bz2
+*.zip
+*.part
+*.sig
+*.sign
+*.txt
+*.log
+*.scm
+*/*.pkg
+*/*.asc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..daf287ab4380
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: Westminboy <westminboy@gmail.com>
+
+pkgname=sylpheed-lite
+_pkgname=sylpheed
+pkgver=3.4.2
+pkgrel=2
+pkgdesc="Lightweight in lightweight and user-friendly e-mail client "
+arch=('i686' 'x86_64')
+url="http://sylpheed.sraoss.jp/en/"
+license=('GPL')
+depends=('gpgme' 'desktop-file-utils')
+makedepends=('openssl')
+options=('!libtool')
+conflicts=('sylpheed')
+install="$pkgname.install"
+source=("http://sylpheed.sraoss.jp/$_pkgname/v3.4/$_pkgname-$pkgver.tar.gz"
+ "http://sylpheed.sraoss.jp/$_pkgname/v3.4/$_pkgname-$pkgver.tar.gz.asc")
+validpgpkeys=('8CF3A5AC417ADE72B0AA4A835024337CC00C2E26') # Hiroyuki Yamamoto
+sha256sums=('a4c47b570a5b565d14ff9933cf2e03fcb895034c1f072f9cd2c4a9867a2f2263'
+ 'SKIP')
+
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --disable-compface \
+ --disable-gtkspell \
+ --disable-ipv6 \
+ --disable-updatecheck
+ make
+
+ # Build Attachment-Tool Plug-in
+ cd plugin/attachment_tool && make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ # Install Attachment-Tool Plug-in
+ cd plugin/attachment_tool
+ make DESTDIR="$pkgdir/" install-plugin
+}
diff --git a/sylpheed-lite.install b/sylpheed-lite.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/sylpheed-lite.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}