summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLászló Várady2023-08-11 13:05:45 +0200
committerLászló Várady2023-08-11 13:05:45 +0200
commit5a7f36aa0665da4363825c26f2f838ef0e3f3b19 (patch)
treecac8aac2c95cde1c1747467bd977f8a9948fc697
parentaaabf2f91c6d876b3909b7212e6150ce1867c57a (diff)
downloadaur-5a7f36aa0665da4363825c26f2f838ef0e3f3b19.tar.gz
Relax keyring version constraints
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--relax-keyring-version-constraints.patch58
3 files changed, 67 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c36ea119a2f9..5920c768fcd2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openconnect-sso
pkgdesc = Wrapper script for OpenConnect supporting Azure AD (SAMLv2) authentication
pkgver = 0.8.0
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/vlaci/openconnect-sso
arch = any
license = GPL3
@@ -26,7 +26,9 @@ pkgbase = openconnect-sso
depends = openconnect
source = https://github.com/vlaci/openconnect-sso/releases/download/v0.8.0/openconnect-sso-0.8.0.tar.gz
source = relax-pyxdg-version-constraints.patch
+ source = relax-keyring-version-constraints.patch
sha256sums = a7bde0a8dd35d7bab3c66f28b420c343c270a7ee45e98e04bfa6ecc6958f5c5b
sha256sums = a74a597fe78299917a276d743b446d90e5677a234824952d2383582e4cdce63c
+ sha256sums = cb723f0e6d72338a893e40dcb186859e25c5f90c2fee7d933532082ea493c1ff
pkgname = openconnect-sso
diff --git a/PKGBUILD b/PKGBUILD
index 746eac37bfb6..d43f9f962582 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=openconnect-sso
pkgver=0.8.0
-pkgrel=4
+pkgrel=5
pkgdesc="Wrapper script for OpenConnect supporting Azure AD (SAMLv2) authentication"
arch=('any')
url="https://github.com/vlaci/openconnect-sso"
@@ -14,13 +14,16 @@ makedepends=('python-setuptools')
checkdepends=('python-pytest' 'python-pytest-asyncio')
optdepends=()
source=("https://github.com/vlaci/openconnect-sso/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
- 'relax-pyxdg-version-constraints.patch')
+ 'relax-pyxdg-version-constraints.patch'
+ 'relax-keyring-version-constraints.patch')
sha256sums=('a7bde0a8dd35d7bab3c66f28b420c343c270a7ee45e98e04bfa6ecc6958f5c5b'
- 'a74a597fe78299917a276d743b446d90e5677a234824952d2383582e4cdce63c')
+ 'a74a597fe78299917a276d743b446d90e5677a234824952d2383582e4cdce63c'
+ 'cb723f0e6d72338a893e40dcb186859e25c5f90c2fee7d933532082ea493c1ff')
prepare() {
cd "$pkgname-$pkgver"
patch --forward --strip=1 --input="${srcdir}/relax-pyxdg-version-constraints.patch"
+ patch --forward --strip=1 --input="${srcdir}/relax-keyring-version-constraints.patch"
}
build() {
diff --git a/relax-keyring-version-constraints.patch b/relax-keyring-version-constraints.patch
new file mode 100644
index 000000000000..8ffcefd96745
--- /dev/null
+++ b/relax-keyring-version-constraints.patch
@@ -0,0 +1,58 @@
+From b58d7c2fe9e46500df67a4532ff34be0fd02fae7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?L=C3=A1szl=C3=B3=20V=C3=A1rady?= <laszlo.varady93@gmail.com>
+Date: Fri, 11 Aug 2023 13:02:27 +0200
+Subject: [PATCH] Relax keyring version constraints
+
+---
+ PKG-INFO | 3 +--
+ pyproject.toml | 2 +-
+ setup.py | 2 +-
+ 3 files changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/PKG-INFO b/PKG-INFO
+index 453a21f..384f5ef 100644
+--- a/PKG-INFO
++++ b/PKG-INFO
+@@ -25,7 +25,7 @@ Requires-Dist: PySocks (>=1.7.1,<2.0.0)
+ Requires-Dist: attrs (>=18.2)
+ Requires-Dist: colorama (>=0.4,<0.5)
+ Requires-Dist: importlib-metadata (>=3.10.0,<4.0.0); python_version < "3.8"
+-Requires-Dist: keyring (>=21.1,<24.0.0)
++Requires-Dist: keyring (>=21.1,<25.0.0)
+ Requires-Dist: lxml (>=4.3,<5.0)
+ Requires-Dist: prompt-toolkit (>=3.0.3,<4.0.0)
+ Requires-Dist: pyxdg (>=0.26,<0.28)
+@@ -201,4 +201,3 @@ $ result/bin/openconnect-sso --help
+ Alternatively you may just [get Poetry](https://python-poetry.org/docs/) and
+ start developing by using the included `Makefile`. Type `make help` to see the
+ possible make targets.
+-
+diff --git a/pyproject.toml b/pyproject.toml
+index 040605f..42f6f0e 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -25,7 +25,7 @@ attrs = ">=18.2"
+ colorama = "^0.4"
+ importlib-metadata = { version = "^3.10.0", python = "<3.8" }
+ lxml = "^4.3"
+-keyring = ">=21.1, <24.0.0"
++keyring = ">=21.1, <25.0.0"
+ prompt-toolkit = "^3.0.3"
+ pyxdg = ">=0.26, <0.28"
+ requests = "^2.22"
+diff --git a/setup.py b/setup.py
+index 4c08404..2b85c98 100644
+--- a/setup.py
++++ b/setup.py
+@@ -11,7 +11,7 @@ install_requires = \
+ ['PySocks>=1.7.1,<2.0.0',
+ 'attrs>=18.2',
+ 'colorama>=0.4,<0.5',
+- 'keyring>=21.1,<24.0.0',
++ 'keyring>=21.1,<25.0.0',
+ 'lxml>=4.3,<5.0',
+ 'prompt-toolkit>=3.0.3,<4.0.0',
+ 'pyxdg>=0.26,<0.28',
+--
+2.41.0
+