summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-07-11 11:08:19 -0400
committerJames An2015-07-11 11:08:19 -0400
commit5ac80ee90aafbadbb1abc249308bd63fa8a55117 (patch)
treefceba0c4cdf2b6c0efd2afa081991da8cba66366
downloadaur-5ac80ee90aafbadbb1abc249308bd63fa8a55117.tar.gz
Initial commit with .gitignore and complete package.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore27
-rw-r--r--PKGBUILD32
-rw-r--r--mapping-ISOLatin1Accent.txt246
4 files changed, 324 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2d780a3ec47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = solr-conf-drupal
+ pkgdesc = Configuration files to enable Drupal to use Solr as its search provider
+ pkgver = 7.x_1.8
+ pkgrel = 2
+ url = http://drupal.org/project/search_api_solr
+ arch = i686
+ arch = x86_64
+ arch = any
+ license = GPL
+ depends = solr>=5
+ optdepends = drupal: Solr client for these configuration files
+ optdepends = aegir: meta-Drupal hosting platform
+ source = http://ftp.drupal.org/files/projects/search_api_solr-7.x-1.8.zip
+ source = mapping-ISOLatin1Accent.txt
+ md5sums = ea3f8918a37f5d581def933921870e2d
+ md5sums = 9f3c8a60a4f09327fad22aeff082c2b3
+
+pkgname = solr-conf-drupal
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f8035620126
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: James An <james@jamesan.ca>
+
+_pkgname=search_api_solr
+pkgname=solr-conf-drupal
+pkgver=7.x_1.8
+pkgrel=2
+pkgdesc="Configuration files to enable Drupal to use Solr as its search provider"
+arch=('i686' 'x86_64' 'any')
+url="http://drupal.org/project/$_pkgname"
+license=('GPL')
+depends=('solr>=5')
+optdepends=(
+ 'drupal: Solr client for these configuration files'
+ 'aegir: meta-Drupal hosting platform'
+)
+source=(
+ "http://ftp.drupal.org/files/projects/$_pkgname-${pkgver/_/-}.zip"
+ 'mapping-ISOLatin1Accent.txt' # From the solr 5.2.1 source tarball: solr-5.2.1/server/solr/configsets/sample_techproducts_configs/conf
+)
+md5sums=('ea3f8918a37f5d581def933921870e2d'
+ '9f3c8a60a4f09327fad22aeff082c2b3')
+
+package() {
+ cd "$_pkgname/solr-conf/5.x"
+
+ for file in *; do
+ install -Dm644 $file "$pkgdir/etc/solr/drupal/conf/$file"
+ done
+ install -Dm644 "$srcdir/mapping-ISOLatin1Accent.txt" "$pkgdir/etc/solr/drupal/conf/mapping-ISOLatin1Accent.txt"
+
+ chown 521:521 "$pkgdir/etc/solr/drupal"
+}
diff --git a/mapping-ISOLatin1Accent.txt b/mapping-ISOLatin1Accent.txt
new file mode 100644
index 000000000000..ede7742581be
--- /dev/null
+++ b/mapping-ISOLatin1Accent.txt
@@ -0,0 +1,246 @@
+# The ASF licenses this file to You under the Apache License, Version 2.0
+# (the "License"); you may not use this file except in compliance with
+# the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# Syntax:
+# "source" => "target"
+# "source".length() > 0 (source cannot be empty.)
+# "target".length() >= 0 (target can be empty.)
+
+# example:
+# "À" => "A"
+# "\u00C0" => "A"
+# "\u00C0" => "\u0041"
+# "ß" => "ss"
+# "\t" => " "
+# "\n" => ""
+
+# À => A
+"\u00C0" => "A"
+
+# Á => A
+"\u00C1" => "A"
+
+# Â => A
+"\u00C2" => "A"
+
+# Ã => A
+"\u00C3" => "A"
+
+# Ä => A
+"\u00C4" => "A"
+
+# Å => A
+"\u00C5" => "A"
+
+# Æ => AE
+"\u00C6" => "AE"
+
+# Ç => C
+"\u00C7" => "C"
+
+# È => E
+"\u00C8" => "E"
+
+# É => E
+"\u00C9" => "E"
+
+# Ê => E
+"\u00CA" => "E"
+
+# Ë => E
+"\u00CB" => "E"
+
+# Ì => I
+"\u00CC" => "I"
+
+# Í => I
+"\u00CD" => "I"
+
+# Î => I
+"\u00CE" => "I"
+
+# Ï => I
+"\u00CF" => "I"
+
+# IJ => IJ
+"\u0132" => "IJ"
+
+# Ð => D
+"\u00D0" => "D"
+
+# Ñ => N
+"\u00D1" => "N"
+
+# Ò => O
+"\u00D2" => "O"
+
+# Ó => O
+"\u00D3" => "O"
+
+# Ô => O
+"\u00D4" => "O"
+
+# Õ => O
+"\u00D5" => "O"
+
+# Ö => O
+"\u00D6" => "O"
+
+# Ø => O
+"\u00D8" => "O"
+
+# Π=> OE
+"\u0152" => "OE"
+
+# Þ
+"\u00DE" => "TH"
+
+# Ù => U
+"\u00D9" => "U"
+
+# Ú => U
+"\u00DA" => "U"
+
+# Û => U
+"\u00DB" => "U"
+
+# Ü => U
+"\u00DC" => "U"
+
+# Ý => Y
+"\u00DD" => "Y"
+
+# Ÿ => Y
+"\u0178" => "Y"
+
+# à => a
+"\u00E0" => "a"
+
+# á => a
+"\u00E1" => "a"
+
+# â => a
+"\u00E2" => "a"
+
+# ã => a
+"\u00E3" => "a"
+
+# ä => a
+"\u00E4" => "a"
+
+# å => a
+"\u00E5" => "a"
+
+# æ => ae
+"\u00E6" => "ae"
+
+# ç => c
+"\u00E7" => "c"
+
+# è => e
+"\u00E8" => "e"
+
+# é => e
+"\u00E9" => "e"
+
+# ê => e
+"\u00EA" => "e"
+
+# ë => e
+"\u00EB" => "e"
+
+# ì => i
+"\u00EC" => "i"
+
+# í => i
+"\u00ED" => "i"
+
+# î => i
+"\u00EE" => "i"
+
+# ï => i
+"\u00EF" => "i"
+
+# ij => ij
+"\u0133" => "ij"
+
+# ð => d
+"\u00F0" => "d"
+
+# ñ => n
+"\u00F1" => "n"
+
+# ò => o
+"\u00F2" => "o"
+
+# ó => o
+"\u00F3" => "o"
+
+# ô => o
+"\u00F4" => "o"
+
+# õ => o
+"\u00F5" => "o"
+
+# ö => o
+"\u00F6" => "o"
+
+# ø => o
+"\u00F8" => "o"
+
+# œ => oe
+"\u0153" => "oe"
+
+# ß => ss
+"\u00DF" => "ss"
+
+# þ => th
+"\u00FE" => "th"
+
+# ù => u
+"\u00F9" => "u"
+
+# ú => u
+"\u00FA" => "u"
+
+# û => u
+"\u00FB" => "u"
+
+# ü => u
+"\u00FC" => "u"
+
+# ý => y
+"\u00FD" => "y"
+
+# ÿ => y
+"\u00FF" => "y"
+
+# ff => ff
+"\uFB00" => "ff"
+
+# fi => fi
+"\uFB01" => "fi"
+
+# fl => fl
+"\uFB02" => "fl"
+
+# ffi => ffi
+"\uFB03" => "ffi"
+
+# ffl => ffl
+"\uFB04" => "ffl"
+
+# ſt => ft
+"\uFB05" => "ft"
+
+# st => st
+"\uFB06" => "st"