summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-06-30 16:49:15 -0500
committerLuis Martinez2022-06-30 16:49:15 -0500
commit5aee344ee46dda1da65ba92e03b891957e458107 (patch)
tree083f347e21f2e7986fb84f460585c0153abf3b1c
parente78c8400c2e22dd0c01fd8c905c84a1113f9b752 (diff)
downloadaur-5aee344ee46dda1da65ba92e03b891957e458107.tar.gz
update to 0.1.19
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md12
-rw-r--r--PKGBUILD21
3 files changed, 24 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e94f5f947f50..571653537533 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pgmpy
pkgdesc = Probabilistic Graphical Model library
- pkgver = 0.1.18
+ pkgver = 0.1.19
pkgrel = 1
url = https://github.com/pgmpy/pgmpy
changelog = CHANGELOG.md
@@ -27,7 +27,7 @@ pkgbase = python-pgmpy
depends = python-statsmodels
depends = python-pytorch
depends = python-tqdm
- source = python-pgmpy-0.1.18.tar.gz::https://github.com/pgmpy/pgmpy/archive/v0.1.18.tar.gz
- sha256sums = 89b5d95e3f5f8e862a2a09c9ef0b7fbd62467803c550f1b8c19759d7ffc679d5
+ source = python-pgmpy-0.1.19.tar.gz::https://github.com/pgmpy/pgmpy/archive/v0.1.19.tar.gz
+ sha256sums = 8f642f15c478d08fae07ac499531862acea5b2c11ace0dd7a629d2682826a71b
pkgname = python-pgmpy
diff --git a/CHANGELOG.md b/CHANGELOG.md
index b264470f8a2e..d2e63992fdeb 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -4,6 +4,18 @@ All notable changes to this project will be documented in this file.
The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
+## [0.1.19] - 2021-06-30
+### Added
+1. Adds checks for arguments to `BayesianNetwork.simulate` method.
+
+### Fixed
+1. Fixes TAN algorithm to use conditional information metric.
+2. Speed ups for all estimation and inference methods.
+3. Fix in stable variant of PC algorithm to give reproducible results.
+4. Fix in `GibbsSampling` for it to work with variables with integral names.
+5. `DAG.active_trail_nodes` allows tuples as variable names.
+6. Fixes CPD and edge creation in `UAIReader`.
+
## [0.1.18] - 2021-03-30
### Fixed
1. Fixes `CausalInference.is_valid_backdoor_adjustment_set` to accept str arguments for `Z`.
diff --git a/PKGBUILD b/PKGBUILD
index 938daa2a4ecb..983add8aab97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=python-pgmpy
-pkgver=0.1.18
+_pkg="${pkgname#python-}"
+pkgver=0.1.19
pkgrel=1
pkgdesc="Probabilistic Graphical Model library"
arch=('any')
@@ -30,33 +31,29 @@ makedepends=(
checkdepends=('python-pytest' 'python-mock' 'python-daft')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('89b5d95e3f5f8e862a2a09c9ef0b7fbd62467803c550f1b8c19759d7ffc679d5')
+sha256sums=('8f642f15c478d08fae07ac499531862acea5b2c11ace0dd7a629d2682826a71b')
prepare() {
- cd "pgmpy-$pkgver"
+ cd "$_pkg-$pkgver"
sed -i '/"tests"/s/tests/*tests*/' setup.py
}
build() {
- cd "pgmpy-$pkgver"
+ cd "$_pkg-$pkgver"
python -m build --wheel --no-isolation
make -C docs man BUILDDIR=_build
}
check() {
- cd "pgmpy-$pkgver"
+ cd "$_pkg-$pkgver"
pytest -x --disable-warnings
}
package() {
- export PYTHONHASHSEED=0
- cd "pgmpy-$pkgver"
- python -m installer --destdir="$pkgdir/" dist/*.whl
+ cd "$_pkg-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 docs/_build/man/pgmpy.1 -t "$pkgdir/usr/share/man/man1/"
-
local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
install -d "$pkgdir/usr/share/licenses/$pkgname/"
- ln -s \
- "$_site/pgmpy-$pkgver.dist-info/LICENSE" \
- "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s "$_site/pgmpy-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
}