summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2022-04-05 10:26:53 +0800
committertaotieren2022-04-05 10:26:53 +0800
commit5b06274f52657cef62eca5ba8d385351d0569ed4 (patch)
tree525f820a529f48fbd1cf60b298cdbc0c2e886eb1
parenteeb83ee6c86d78b7f620dc498ef2ffc7e2466538 (diff)
downloadaur-5b06274f52657cef62eca5ba8d385351d0569ed4.tar.gz
update 2022.04
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 25 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e587f821549f..20e22c308cdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,22 @@
pkgbase = nuclei-openocd
pkgdesc = nuclei-openocd 是 Nuclei Studio IDE 的调试工具。
- pkgver = 2022.01
- pkgrel = 2
+ pkgver = 2022.04
+ pkgrel = 1
url = https://www.nucleisys.com/download.php
arch = x86_64
license = unknow
+ makedepends = libftdi-compat
+ makedepends = libusb-compat
+ makedepends = hidapi
+ makedepends = libudev.so
optdepends = nucleistudioide: Nuclei Studio IDE 是基于 MCU Eclipse IDE 开发的一款针对芯来公司处理器核产品的集成开发环境工具,用于 RISC-V 开发继承了 Eclipse IDE 平台的各种优势。
optdepends = jlink-software-and-documentation: Segger JLink software & documentation pack for Linux
optdepends = embedded-studio-risc-v: Segger Embedded Studio for RISC-V
options = !strip
- source = https://www.nucleisys.com/upload/files/toochain/openocd/nuclei-openocd-2022.01-linux-x64.tgz
- sha256sums = 0c55a43a09bf6f75959fab44fcec6f785ed9c1a40f62d746089c654ea3409074
+ source = https://www.nucleisys.com/upload/files/toochain/openocd/nuclei-openocd-2022.04-linux-x64.tgz
+ sha256sums = 658c8eca2faea4f6b15ab27e49da95dd027f87fef4eba9c2b59fd0a2ff268eff
pkgname = nuclei-openocd
+ depends = nuclei-openocd-bin
+
+pkgname = nuclei-openocd-bin
diff --git a/PKGBUILD b/PKGBUILD
index 88c88ac7e374..269a6a11e5bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: taotieren <admin@taotieren.com>
-pkgname=nuclei-openocd
-pkgver=2022.01
-pkgrel=2
+pkgbase=nuclei-openocd
+pkgname=(nuclei-openocd nuclei-openocd-bin)
+pkgver=2022.04
+pkgrel=1
pkgdesc="nuclei-openocd 是 Nuclei Studio IDE 的调试工具。"
arch=("x86_64")
-makedepends=()
+makedepends=('libftdi-compat' 'libusb-compat' 'hidapi' 'libudev.so')
depends=()
optdepends=('nucleistudioide: Nuclei Studio IDE 是基于 MCU Eclipse IDE 开发的一款针对芯来公司处理器核产品的集成开发环境工具,用于 RISC-V 开发继承了 Eclipse IDE 平台的各种优势。'
'jlink-software-and-documentation: Segger JLink software & documentation pack for Linux'
@@ -16,9 +17,13 @@ license=('unknow')
options=(!strip)
source=("https://www.nucleisys.com/upload/files/toochain/openocd/nuclei-openocd-${pkgver}-linux-x64.tgz")
-sha256sums=('0c55a43a09bf6f75959fab44fcec6f785ed9c1a40f62d746089c654ea3409074')
+sha256sums=('658c8eca2faea4f6b15ab27e49da95dd027f87fef4eba9c2b59fd0a2ff268eff')
-package() {
+package_nuclei-openocd() {
+ depends=('nuclei-openocd-bin')
+}
+
+package_nuclei-openocd-bin() {
cd "$srcdir"
msg2 'Installing Nuclei OpenOCD'
@@ -27,9 +32,9 @@ package() {
tar zxf "nuclei-openocd-${pkgver}-linux-x64.tgz"
- mv "Nuclei/openocd" "${pkgdir}/opt/nuclei"
- ln -sf "/opt/nuclei/openocd/${pkgver}" "${pkgdir}/opt/nuclei/NucleiStudio/toolchain/openocd"
- ln -sf "/opt/nuclei/openocd/${pkgver}" "${pkgdir}/opt/SEGGER/Embedded-Studio-RISC-V/Nuclei_Toolchain/openocd"
+ mv "Nuclei/openocd/${pkgver}/" "${pkgdir}/opt/nuclei/openocd"
+ ln -sf "/opt/nuclei/openocd/" "${pkgdir}/opt/nuclei/NucleiStudio/toolchain/openocd"
+ ln -sf "/opt/nuclei/openocd/" "${pkgdir}/opt/SEGGER/Embedded-Studio-RISC-V/Nuclei_Toolchain/openocd"
}
#