summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvgeniy Alekseev2017-06-02 13:50:15 +0300
committerEvgeniy Alekseev2017-06-02 13:50:15 +0300
commit5b0691cd87d86073f478f2dba86b6dbb25a04506 (patch)
tree1df7e5c8963bcfb2cbba95d3a84e3cceb9f38fa1
parent9434092efc55bf2ce060e4fefe9674736810fdd6 (diff)
downloadaur-5b0691cd87d86073f478f2dba86b6dbb25a04506.tar.gz
bump scidavis
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
-rw-r--r--scidavis-python2.patch62
3 files changed, 84 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee189b5806bd..cd537690f2bb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 8 11:18:28 UTC 2016
+# Fri Jun 2 10:48:41 UTC 2017
pkgbase = scidavis
pkgdesc = Application for Scientific Data Analysis and Visualization, fork of QtiPlot
- pkgver = 1.14
- pkgrel = 4
+ pkgver = 1.17
+ pkgrel = 1
url = http://scidavis.sourceforge.net/
install = scidavis.install
arch = i686
@@ -19,12 +19,12 @@ pkgbase = scidavis
depends = shared-mime-info
depends = qwt5
depends = qwtplot3d
- source = http://prdownloads.sourceforge.net/sourceforge/scidavis/scidavis-1.14.tar.gz
- source = https://sourceforge.net/p/scidavis/scidavis-bugs/_discuss/thread/e0094938/8b60/attachment/fix_wrong_values_on_parameters_errors.patch
+ source = http://prdownloads.sourceforge.net/sourceforge/scidavis/scidavis-1.17.tar.gz
source = https://sourceforge.net/p/scidavis/scidavis-bugs/_discuss/thread/fa133ad9/b8d8/attachment/scidavis-qwt5.patch
- md5sums = 6b5fd39c17ed67cd64c77ac214099b2e
- md5sums = 89247212a4fdaa34894a6562fa2b2457
+ source = scidavis-python2.patch
+ md5sums = 4d5356c64bf103e4c1dd06f8a35b8a50
md5sums = 4166c8637deb81bce31d5ee511586245
+ md5sums = 70665013c8f456c0ebbff8373d4c8d30
pkgname = scidavis
diff --git a/PKGBUILD b/PKGBUILD
index 7aeb3a431012..ff8b5b6489f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# Contributor: Alexander <chronischzuspaet at gmail dot com> Kempen
pkgname=scidavis
-pkgver=1.14
-pkgrel=4
+pkgver=1.17
+pkgrel=1
pkgdesc="Application for Scientific Data Analysis and Visualization, fork of QtiPlot"
arch=('i686' 'x86_64')
url="http://scidavis.sourceforge.net/"
@@ -15,24 +15,27 @@ makedepends=('boost' 'cmake')
depends=('gsl' 'glu' 'mesa' 'muparser' 'python2-pyqt4' 'shared-mime-info'
'qwt5' 'qwtplot3d')
source=("http://prdownloads.sourceforge.net/sourceforge/scidavis/${pkgname}-${pkgver}.tar.gz"
- "https://sourceforge.net/p/scidavis/scidavis-bugs/_discuss/thread/e0094938/8b60/attachment/fix_wrong_values_on_parameters_errors.patch"
- "https://sourceforge.net/p/scidavis/scidavis-bugs/_discuss/thread/fa133ad9/b8d8/attachment/scidavis-qwt5.patch")
-md5sums=('6b5fd39c17ed67cd64c77ac214099b2e'
- '89247212a4fdaa34894a6562fa2b2457'
- '4166c8637deb81bce31d5ee511586245')
+ "https://sourceforge.net/p/scidavis/scidavis-bugs/_discuss/thread/fa133ad9/b8d8/attachment/scidavis-qwt5.patch"
+ "scidavis-python2.patch")
+md5sums=('4d5356c64bf103e4c1dd06f8a35b8a50'
+ '4166c8637deb81bce31d5ee511586245'
+ '70665013c8f456c0ebbff8373d4c8d30')
install="${pkgname}.install"
prepare() {
- # fix https://sourceforge.net/p/scidavis/scidavis-bugs/276/
- patch -p0 -i "fix_wrong_values_on_parameters_errors.patch" "${pkgname}-${pkgver}/libscidavis/src/Fit.cpp"
-
# fix qwt
- patch -p0 -i "scidavis-qwt5.patch"
+ cd "${pkgname}-${pkgver}"
+ patch -p1 -i "../scidavis-qwt5.patch"
+
+ # replace to python2
+ find . -name '*.py' -type f -exec \
+ sed -i 's|/usr/bin/python|/usr/bin/python2|' {} \;
+ patch -p1 -i "../scidavis-python2.patch"
}
build() {
cd "${pkgname}-${pkgver}"
- qmake-qt4
+ qmake-qt4 CONFIG+="liborigin python"
make
}
diff --git a/scidavis-python2.patch b/scidavis-python2.patch
new file mode 100644
index 000000000000..87dc0e908419
--- /dev/null
+++ b/scidavis-python2.patch
@@ -0,0 +1,62 @@
+diff -ruN scidavis-1.17-orig/libscidavis/python.pri scidavis-1.17/libscidavis/python.pri
+--- scidavis-1.17-orig/libscidavis/python.pri 2017-06-02 13:38:52.806445430 +0300
++++ scidavis-1.17/libscidavis/python.pri 2017-06-02 13:39:55.710957205 +0300
+@@ -16,18 +16,18 @@
+ SOURCES += src/PythonScript.cpp src/PythonScripting.cpp
+
+ unix {
+- INCLUDEPATH += $$system(python-config --includes|sed -e 's/-I//')
++ INCLUDEPATH += $$system(python2-config --includes|sed -e 's/-I//')
+ osx_dist {
+ DEFINES += PYTHONHOME=/Applications/scidavis.app/Contents/Resources
+- }
++ }
+ system(mkdir -p $${SIP_DIR})
+- system($$system(python python-sipcmd.py) $$system(python-config --includes) -c $${SIP_DIR} src/scidavis.sip)
++ system($$system(python2 python-sipcmd.py) $$system(python2-config --includes) -c $${SIP_DIR} src/scidavis.sip)
+ }
+
+ win32 {
+ mxe {
+ DEFINES += SIP_STATIC_MODULE
+- system($$system(python python-sipcmd.py) -c $${SIP_DIR} src/scidavis.sip)
++ system($$system(python2 python-sipcmd.py) -c $${SIP_DIR} src/scidavis.sip)
+ } else {
+ INCLUDEPATH += $$system(call ../python-includepath.py)
+ # TODO: fix the command below (only really necessary if SIP_DIR != MOC/OBJECTS_DIR)
+diff -ruN scidavis-1.17-orig/scidavis/python.pri scidavis-1.17/scidavis/python.pri
+--- scidavis-1.17-orig/scidavis/python.pri 2017-06-02 13:46:20.953100711 +0300
++++ scidavis-1.17/scidavis/python.pri 2017-06-02 13:47:05.315306277 +0300
+@@ -9,10 +9,10 @@
+
+ compiledScidavisrc.target = scidavisrc.pyc
+ compiledScidavisrc.depends = scidavisrc.py
+- compiledScidavisrc.commands = python -m py_compile scidavisrc.py
++ compiledScidavisrc.commands = python2 -m py_compile scidavisrc.py
+ compiledScidavisUtil.target = scidavisUtil.pyc
+ compiledScidavisUtil.depends = scidavisUtil.py
+- compiledScidavisUtil.commands = python -m py_compile scidavisUtil.py
++ compiledScidavisUtil.commands = python2 -m py_compile scidavisUtil.py
+ QMAKE_EXTRA_TARGETS += compiledScidavisrc compiledScidavisUtil
+ PRE_TARGETDEPS += scidavisrc.pyc scidavisUtil.pyc
+
+@@ -24,16 +24,16 @@
+
+ message("Making PyQt bindings via SIP")
+ unix {
+- INCLUDEPATH += $$system(python-config --includes|sed -e 's/-I//')
++ INCLUDEPATH += $$system(python2-config --includes|sed -e 's/-I//')
+ osx_dist {
+ DEFINES += PYTHONHOME=/Applications/scidavis.app/Contents/Resources
+ } else {
+ macx {
+ LIBS += -framework Python
+ } else {
+- LIBS += $$system(python -c "\"from distutils import sysconfig; print '-lpython'+sysconfig.get_config_var('VERSION')\"")
++ LIBS += $$system(python2 -c "\"from distutils import sysconfig; print '-lpython'+sysconfig.get_config_var('VERSION')\"")
+ }
+- }
++ }
+ LIBS += -lm
+ }
+