summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-06-26 17:19:05 -0600
committerMark Wagie2022-06-26 17:19:05 -0600
commit5b12a964c5ef3248952e9fbf95d75d6d3f3792fe (patch)
tree702ee34fd44320e58c9036ddf41c59a90bad39b5
parent0e5c9b03382fc86f617067bb2ef680ed39195e52 (diff)
downloadaur-5b12a964c5ef3248952e9fbf95d75d6d3f3792fe.tar.gz
0.2.6+2+g9f430c2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD45
2 files changed, 28 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 661ec78581e7..738f62055352 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = thiefmd
pkgdesc = The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter
- pkgver = 0.2.5
+ pkgver = 0.2.6+2+g9f430c2
pkgrel = 1
url = https://thiefmd.com
arch = x86_64
@@ -18,9 +18,12 @@ pkgbase = thiefmd
depends = link-grammar
depends = libhandy
depends = webkit2gtk
- source = git+https://github.com/kmwallio/ThiefMD.git#commit=039ec4f81170b468d2eb5cf3b9e0b0cae7b59097
+ source = git+https://github.com/kmwallio/ThiefMD.git#commit=9f430c25f41983a0e7b9ddac88c502ad7e1bdd2f
source = git+https://github.com/ThiefMD/BiBtex-vala.git
+ source = git+https://github.com/ThiefMD/forem-vala.git
source = git+https://github.com/ThiefMD/ghost-vala.git
+ source = git+https://github.com/TwiRp/hashnode-vala.git
+ source = git+https://github.com/ThiefMD/medium-vala.git
source = git+https://github.com/TwiRp/ultheme-vala.git
source = git+https://github.com/ThiefMD/wordpress-vala.git
source = git+https://github.com/ThiefMD/writeas-vala.git
@@ -34,5 +37,8 @@ pkgbase = thiefmd
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = thiefmd
diff --git a/PKGBUILD b/PKGBUILD
index 7c796b30249c..7cdcc95a7654 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=thiefmd
-pkgver=0.2.5
-_codename=stability
+pkgver=0.2.6+2+g9f430c2
pkgrel=1
pkgdesc="The markdown editor worth stealing. Inspired by Ulysses, based on code from Quilter"
arch=('x86_64' 'aarch64')
@@ -10,10 +9,13 @@ license=('GPL3')
depends=('clutter' 'discount' 'gtksourceview4' 'gtkspell3' 'libarchive' 'libgee'
'link-grammar' 'libhandy' 'webkit2gtk')
makedepends=('git' 'meson' 'vala')
-_commit=039ec4f81170b468d2eb5cf3b9e0b0cae7b59097
+_commit=9f430c25f41983a0e7b9ddac88c502ad7e1bdd2f
source=("git+https://github.com/kmwallio/ThiefMD.git#commit=${_commit}"
'git+https://github.com/ThiefMD/BiBtex-vala.git'
+ 'git+https://github.com/ThiefMD/forem-vala.git'
'git+https://github.com/ThiefMD/ghost-vala.git'
+ 'git+https://github.com/TwiRp/hashnode-vala.git'
+ 'git+https://github.com/ThiefMD/medium-vala.git'
'git+https://github.com/TwiRp/ultheme-vala.git'
'git+https://github.com/ThiefMD/wordpress-vala.git'
'git+https://github.com/ThiefMD/writeas-vala.git'
@@ -26,36 +28,29 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
cd "$srcdir/ThiefMD"
- git describe --tags | sed "s/^v//;s/-${_codename}//;s/-/+/g"
+ git describe --tags | sed 's/^v//;s/-/+/g'
}
prepare() {
cd "$srcdir/ThiefMD"
- git submodule init src/bibtex
- git config submodule.BiBtex-vala.url $srcdir/BiBtex-vala
-
- git submodule init src/ghost
- git config submodule.ghost-vala.url $srcdir/ghost-vala
-
- git submodule init src/ultheme
- git config submodule.ultheme-vala.url $srcdir/ultheme-vala
-
- git submodule init src/wordpress
- git config submodule.wordpress-vala.url $srcdir/wordpress-vala
-
- git submodule init src/writeas
- git config submodule.writeas-vala.url $srcdir/writeas-vala
-
- git submodule init src/writegood
- git config submodule.libwritegood-vala.url $srcdir/libwritegood-vala
-
- git submodule init data/language-specs
- git config submodule.custom-gtksourceview-languages.url $srcdir/custom-gtksourceview-languages
-
+ git submodule init
+ git config submodule.src/bibtex.url "$srcdir/BiBtex-vala"
+ git config submodule.src/forem.url "$srcdir/forem-vala"
+ git config submodule.src/ghost.url "$srcdir/ghost-vala"
+ git config submodule.src/hashnode.url "$srcdir/hashnode-vala"
+ git config submodule.src/medium.url "$srcdir/medium-vala"
+ git config submodule.src/ultheme.url "$srcdir/ultheme-vala"
+ git config submodule.src/wordpress.url "$srcdir/wordpress-vala"
+ git config submodule.src/writeas.url "$srcdir/writeas-vala"
+ git config submodule.src/writegood.url "$srcdir/libwritegood-vala"
+ git config submodule.data/language-specs.url "$srcdir/custom-gtksourceview-languages"
git submodule update
}