summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Sonntag2022-05-02 22:18:59 +0200
committerJan Sonntag2022-05-02 22:18:59 +0200
commit5b1f8b70c46bd8892c4f4acb897d0b154c8d8a65 (patch)
tree2d202f73aaa52509e82d15b4b52275607c87b3ac
downloadaur-5b1f8b70c46bd8892c4f4acb897d0b154c8d8a65.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c37940b2c1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = asciigraph-bin
+ pkgdesc = Go package to make lightweight ASCII line graph ╭┈╯ in command line apps with no other dependencies
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = https://github.com/guptarohit/asciigraph
+ arch = x86_64
+ license = BSD
+ provides = asciigraph
+ conflicts = asciigraph
+ source = asciigraph-bin-0.5.4.tar.gz::https://github.com/guptarohit/asciigraph/releases/download/v0.5.4/asciigraph_0.5.4_Linux_x86_64.tar.gz
+ sha256sums = 62a8680d0bf66868103aa893923864b4ebf2fc211c0168dc835b6eb79c28aaca
+
+pkgname = asciigraph-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2c4eecced2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Jan Sonntag <jaso35 at gmail dot com>
+
+pkgname=asciigraph-bin
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="Go package to make lightweight ASCII line graph ╭┈╯ in command line apps with no other dependencies"
+arch=('x86_64')
+url='https://github.com/guptarohit/asciigraph'
+license=('BSD')
+provides=('asciigraph')
+conflicts=('asciigraph')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/guptarohit/asciigraph/releases/download/v${pkgver}/asciigraph_${pkgver}_Linux_${arch}.tar.gz")
+sha256sums=('62a8680d0bf66868103aa893923864b4ebf2fc211c0168dc835b6eb79c28aaca')
+
+package() {
+ install -Dm755 asciigraph "${pkgdir}/usr/bin/asciigraph"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/asciigraph/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/asciigraph/README.md"
+}