summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:22:51 +0200
committerM0Rf302015-06-17 15:22:51 +0200
commit5b2038e00965ceedab4bfd43f65d0565906b89d9 (patch)
treee4562dd30735d30e289db60f39544acbc03067a0
downloadaur-5b2038e00965ceedab4bfd43f65d0565906b89d9.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
-rw-r--r--authpuppy.install7
-rw-r--r--httpd-authpuppy.conf23
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9fef4a0cbcd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = authpuppy
+ pkgdesc = A new implementation of the authentication server for Wifidog networks.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.authpuppy.org/
+ install = authpuppy.install
+ arch = any
+ license = GPL
+ depends = apache
+ depends = php
+ depends = mysql
+ options = !strip
+ source = http://launchpadlibrarian.net/78643482/authpuppy-1.0.0-stable.tgz
+ source = httpd-authpuppy.conf
+ md5sums = a168ba71cd0e4347ab0983daf6d8e150
+ md5sums = 1b008fb4616c661a22fcb5584fce8846
+
+pkgname = authpuppy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2196057f705c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Mantainer: M0Rf30
+
+pkgname=authpuppy
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A new implementation of the authentication server for Wifidog networks."
+arch=('any')
+url="http://www.authpuppy.org/"
+license=('GPL')
+source=("http://launchpadlibrarian.net/78643482/$pkgname-$pkgver-stable.tgz"
+httpd-authpuppy.conf)
+depends=('apache' 'php' 'mysql')
+install='authpuppy.install'
+options=(!strip)
+
+package() {
+ cd ${srcdir}
+ mkdir -p $pkgdir/srv/http/
+ cp -r authpuppy $pkgdir/srv/http/
+ chmod 777 -R $pkgdir/srv/http/authpuppy/*
+ mkdir -p $pkgdir/etc/httpd/conf/extra
+ cp httpd-authpuppy.conf $pkgdir/etc/httpd/conf/extra
+ mkdir -p $pkgdir/var/log/httpd/authpuppy/
+}
+
+md5sums=('a168ba71cd0e4347ab0983daf6d8e150'
+ '1b008fb4616c661a22fcb5584fce8846')
diff --git a/authpuppy.install b/authpuppy.install
new file mode 100644
index 000000000000..c37bc159951f
--- /dev/null
+++ b/authpuppy.install
@@ -0,0 +1,7 @@
+## arg 1: the new package version
+post_install() {
+ echo " You need to setup Apache to serve /srv/http/wifidog-auth then open install.php in your browser to finish installation"
+ echo " Add your httpd-authpuppy.conf in httpd.conf "
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/httpd-authpuppy.conf b/httpd-authpuppy.conf
new file mode 100644
index 000000000000..24d6e155c316
--- /dev/null
+++ b/httpd-authpuppy.conf
@@ -0,0 +1,23 @@
+<VirtualHost *:80>
+ ServerAdmin webmaster@localhost
+ ServerName authpuppy.localhost
+ ServerAlias authpuppy.test
+ DocumentRoot "/srv/http/authpuppy/web"
+ <Directory /srv/http//authpuppy/web/>
+ Options Indexes FollowSymLinks MultiViews
+ AllowOverride All
+ Order allow,deny
+ allow from all
+ </Directory>
+
+ Alias /auth "/srv/http/authpuppy/web"
+ <Directory "/srv/http/authpuppy/web">
+ AllowOverride All
+ Allow from All
+ </Directory>
+ ErrorLog "/var/log/httpd/authpuppy/error.log"
+ CustomLog "/var/log/httpd/authpuppy/access.log" combined
+</VirtualHost>
+
+
+