summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAli Molaei2019-12-31 12:48:54 +0330
committerAli Molaei2019-12-31 12:48:54 +0330
commit5b28378d781977e88ecc812d213522b78d15855f (patch)
treec612db7f5565b572bda66d4936c4a2d219ec5189
downloadaur-5b28378d781977e88ecc812d213522b78d15855f.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD19
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a930b95093d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = hashem
+ pkgdesc = Mr. Hashemi Programming Language
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/mr-hashemi/mr-hashemi
+ arch = any
+ license = UPL
+ source = hashem-0.4::https://github.com/mr-hashemi/mr-hashemi/releases/download/0.4/hashem
+ source = https://raw.githubusercontent.com/mr-hashemi/mr-hashemi/master/LICENSE
+ sha256sums = a3b2bad566e9043bca1eeaecfdbf8be8d0737d259e804b10ce9c473f608cd951
+ sha256sums = 9c93d0dd0b920a1710d7739412ea00e78fc81e21c1afeaf8c794630e3f42af42
+
+pkgname = hashem
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5d7b742209e5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+hashem
+hashem-*
+LICENSE
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd6cb527e493
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Ali Molaei <ali dot molaei at protonmail dot com>
+
+pkgname=hashem
+pkgver=0.04
+pkgrel=1
+pkgdesc="Mr. Hashemi Programming Language"
+url="https://github.com/mr-hashemi/mr-hashemi"
+arch=(any)
+license=('UPL')
+source=("${pkgname}-${pkgver}::${url}/releases/download/${pkgver}/hashem"
+ "https://raw.githubusercontent.com/mr-hashemi/mr-hashemi/master/LICENSE")
+
+sha256sums=('a3b2bad566e9043bca1eeaecfdbf8be8d0737d259e804b10ce9c473f608cd951'
+ '9c93d0dd0b920a1710d7739412ea00e78fc81e21c1afeaf8c794630e3f42af42')
+
+package() {
+ install -Dm755 "${srcdir}/hashem-${pkgver}" "${pkgdir}/usr/bin/hashem"
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 "${srcdir}/LICENSE"
+}