summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThammachart2023-01-19 01:28:38 +0700
committerThammachart2023-01-19 01:28:38 +0700
commit5b2a88b59104aa09977432962c3148382e4ddffc (patch)
treeead208c2fa73ab22780051b98187c7d6b82593a2
parentd24485a7770e49050e346d6641fe13d903054c5d (diff)
downloadaur-5b2a88b59104aa09977432962c3148382e4ddffc.tar.gz
build steps changed, credit to ttf-firacode-nerd
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e463fd68ffba..2aaf1ac4ebbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nerd-fonts-cascadia-code
pkgdesc = Patched Cascadia Code (Caskaydia Cove) font with extra glyphs
pkgver = 2.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ryanoasis/nerd-fonts
arch = any
groups = nerd-fonts
@@ -10,8 +10,6 @@ pkgbase = nerd-fonts-cascadia-code
conflicts = nerd-fonts-complete
conflicts = nerd-fonts-git
source = https://github.com/ryanoasis/nerd-fonts/releases/download/v2.3.0/CascadiaCode.zip
- source = https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v2.3.0/LICENSE
sha256sums = 417c3e57a1185bcd432592fa7e1c182ac2ccd559e79ba25a5f7778ee346206f8
- sha256sums = 1f6ad4edae6479aaace3112ede5279a23284ae54b2a34db66357aef5f64df160
pkgname = nerd-fonts-cascadia-code
diff --git a/PKGBUILD b/PKGBUILD
index 127a4f1402d2..15c223765f8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=nerd-fonts-cascadia-code
pkgver=2.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Patched Cascadia Code (Caskaydia Cove) font with extra glyphs"
arch=("any")
url="https://github.com/ryanoasis/nerd-fonts"
@@ -8,12 +8,14 @@ license=("MIT")
depends=("fontconfig")
conflicts=("nerd-fonts-complete" "nerd-fonts-git")
groups=("nerd-fonts")
-source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v${pkgver}/CascadiaCode.zip"
- "https://raw.githubusercontent.com/ryanoasis/nerd-fonts/v${pkgver}/LICENSE")
-sha256sums=("417c3e57a1185bcd432592fa7e1c182ac2ccd559e79ba25a5f7778ee346206f8"
- "1f6ad4edae6479aaace3112ede5279a23284ae54b2a34db66357aef5f64df160")
+source=("https://github.com/ryanoasis/nerd-fonts/releases/download/v${pkgver}/CascadiaCode.zip")
+sha256sums=("417c3e57a1185bcd432592fa7e1c182ac2ccd559e79ba25a5f7778ee346206f8")
+
+prepare() {
+ find "${srcdir}" -name '*Windows*' -delete
+}
package() {
- find . -iname "*.otf" -not -iname "*Windows Compatible*" -execdir install -Dm644 {} "${pkgdir}/usr/share/fonts/OTF/{}" \;
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 *.otf -t "${pkgdir}/usr/share/fonts/OTF"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}