summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrich_o2015-06-10 11:00:01 +0200
committerrich_o2015-06-10 11:00:01 +0200
commit5b39441efbf39fa4f16cc2fc6dd90c98578d1a0b (patch)
tree62f5e3c7b5d520f861634f4f4f5112e4ed6bfb99
downloadaur-5b39441efbf39fa4f16cc2fc6dd90c98578d1a0b.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b23c78ddaad8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = paperkey
+ pkgdesc = Make long term backups of OpenPGP keys by printing only the secret bits on paper.
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://www.jabberwocky.com/software/paperkey/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = glibc
+ source = http://www.jabberwocky.com/software/paperkey/paperkey-1.3.tar.gz
+ sha256sums = 5b57d7522336fb65c4c398eec27bf44ec0aaa35926157b79a76423231792cbfb
+
+pkgname = paperkey
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cc3863e5881a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg
+src
+*.gz
+*.xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7eb1ecf2acb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: rich_o <aurua@riseup.net>
+
+pkgname=paperkey
+pkgver=1.3
+pkgrel=1
+pkgdesc="Make long term backups of OpenPGP keys by printing only the secret bits on paper."
+arch=('i686' 'x86_64')
+url="http://www.jabberwocky.com/software/paperkey/"
+license=('GPL2')
+depends=('glibc')
+source=(http://www.jabberwocky.com/software/$pkgname/$pkgname-$pkgver.tar.gz)
+sha256sums=('5b57d7522336fb65c4c398eec27bf44ec0aaa35926157b79a76423231792cbfb')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR=$pkgdir install
+}