summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2022-03-22 13:26:20 +0800
committerUniversebenzene2022-03-22 13:26:20 +0800
commit5b3d3e5b2eca1adf6d6d7d7ee01067970652e19f (patch)
tree39bf8f754e13f8427049224b6a3c8aef5478e6f2
parenteb73d690b58b98c296e75fedb4f35bdc7cdd9351 (diff)
downloadaur-5b3d3e5b2eca1adf6d6d7d7ee01067970652e19f.tar.gz
Update to version 0.6
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD22
2 files changed, 27 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c99348636cd9..26429ca5df87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,34 @@
pkgbase = python-regions
pkgdesc = Astropy affilated package for region handling
- pkgver = 0.5
+ pkgver = 0.6
pkgrel = 1
url = http://astropy-regions.readthedocs.io
arch = i686
arch = x86_64
license = BSD
checkdepends = python-pytest-astropy
+ checkdepends = python-matplotlib
makedepends = cython
makedepends = python-setuptools-scm
- makedepends = python-astropy
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-numpy
makedepends = python-extension-helpers
+ makedepends = python-astropy
makedepends = python-sphinx-astropy
makedepends = python-shapely
- source = https://files.pythonhosted.org/packages/source/r/regions/regions-0.5.tar.gz
- md5sums = 10a6523b329b862bb5c4f8aa6b7b0f1b
+ source = https://files.pythonhosted.org/packages/source/r/regions/regions-0.6.tar.gz
+ md5sums = dad3ff173994b5991b56de31d9c712f6
pkgname = python-regions
- depends = python>=3.6
- depends = python-numpy>=1.16
- depends = python-astropy>=3.2
- optdepends = python-matplotlib>=2.0: Plotting support
+ depends = python>=3.8
+ depends = python-numpy>=1.18
+ depends = python-astropy>=5.0
+ optdepends = python-matplotlib>=3.1: Plotting support
optdepends = python-shapely: Managing geometric objects
optdepends = python-regions-doc: Documentation for AstroPy Regions
pkgname = python-regions-doc
pkgdesc = Documentation for AstroPy Regions
+ arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 4e1e64778a4b..df7c28a9f157 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,28 @@
pkgbase=python-regions
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=0.5
+pkgver=0.6
pkgrel=1
pkgdesc="Astropy affilated package for region handling"
arch=('i686' 'x86_64')
url="http://astropy-regions.readthedocs.io"
license=('BSD')
-makedepends=('cython' 'python-setuptools-scm' 'python-astropy' 'python-extension-helpers' 'python-sphinx-astropy' 'python-shapely')
-checkdepends=('python-pytest-astropy')
+makedepends=('cython' 'python-setuptools-scm' 'python-wheel' 'python-build' 'python-installer' 'python-numpy' 'python-extension-helpers' 'python-astropy' 'python-sphinx-astropy' 'python-shapely')
+checkdepends=('python-pytest-astropy' 'python-matplotlib')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('10a6523b329b862bb5c4f8aa6b7b0f1b')
+md5sums=('dad3ff173994b5991b56de31d9c712f6')
prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ sed -i -e "/cython/s/==/>=/" -e "/oldest-supported-numpy/d" pyproject.toml
export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
}
build() {
msg "Building Python3"
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
msg "Building Docs"
cd ${srcdir}/${_pyname}-${pkgver}/docs
@@ -30,23 +33,24 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
- pytest "build/lib.linux-${CARCH}-${_pyver}"
+ pytest "build/lib.linux-${CARCH}-${_pyver}" || warning "Tests failed"
}
package_python-regions() {
- depends=('python>=3.6' 'python-numpy>=1.16' 'python-astropy>=3.2')
- optdepends=('python-matplotlib>=2.0: Plotting support'
+ depends=('python>=3.8' 'python-numpy>=1.18' 'python-astropy>=5.0')
+ optdepends=('python-matplotlib>=3.1: Plotting support'
'python-shapely: Managing geometric objects'
'python-regions-doc: Documentation for AstroPy Regions')
cd ${srcdir}/${_pyname}-${pkgver}
install -Dm644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}
package_python-regions-doc() {
pkgdesc="Documentation for AstroPy Regions"
+ arch=('any')
cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../../LICENSE.rst